Modify

Opened 6 years ago

Last modified 6 years ago

#7817 new defect

Does WikiExportPlugin work with OpenOffice 3.2 and Python 2.6?

Reported by: verena.roeoesli@… Owned by: Claudio Manuel Fernández Barreiro
Priority: normal Component: WikiExportPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

I tried to Install your Plugin on my Trac site which runs on SUSE Linux 10.1 with OpenOffice 3.2 and Python 2.6. Now i've got the issue that i can't get it to run. I don't even get the entry in the plugin section.

In the Trac Log File I get the following entry

2010-10-13 10:07:41,733 Trac[loader] ERROR: Skipping "TracWikiExportPlugin = exportplugin.export": (can't import "ImportError: No module named uno")

As described in #4403, I insertde in the file openoffice.py the line sys.path.append("/usr/lib64/ooo3/program") bevore importing uno, but it did not make any difference...

Any ideas what I'm missing? Does it eaven work with OpenOffice 3.2?

Thanks for your help

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by Claudio Manuel Fernández Barreiro

Sorry for the delay. The plugin was developed under OpenOffice 2.4 and Python 2.5. In OO 3 the sdk change. Probably the plugin is not compatible with new SDK

comment:2 Changed 6 years ago by Claudio Manuel Fernández Barreiro

I'm studying the change of the plugin for use the new OpenOffice and Python. I posted when i finish the development.

Modify Ticket

Action
as new The owner will remain Claudio Manuel Fernández Barreiro.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.