Opened 9 years ago

Closed 9 years ago

#7861 closed defect (invalid)

404 error with new GitPlugin version

Reported by: zaran.krleza@… Owned by: Herbert Valerio Riedel
Priority: high Component: GitPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.12



Since i upgraded my GitPlugin to the latest revision of github (it was yesterday). I get a 404 "Not found" error when i clicking on "Browse source". I use a cached repository plugin (revisions are stored in the database). I tried from a fresh install, and with another git repository. But i alwas get the same error in trac.log :

Trac[PyGIT] DEBUG: PyGIT.Storage instance 23112848 constructed
Trac[PyGIT] DEBUG: requested weak PyGIT.Storage instance 23112848 for '/****/alias.git'
Trac[git_fs] DEBUG: enabled CachedRepository for '/****/alias.git'
Trac[PyGIT] DEBUG: triggered rebuild of commit tree db for 23112848
Trac[PyGIT] DEBUG: rebuilt commit tree db for 23112848 with 0 entries (took 45.2 ms)
Trac[main] WARNING: HTTPNotFound: 404 Invalid changeset number (No changeset 653a3a6c0817f600cefc9d2ebf3950aa19869f3f in the repository)

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by anonymous

Could you try with cached_repository = false for the mean time?

comment:2 Changed 9 years ago by anonymous

I fixed this problem. It turned out that it was a problem in my config. Thank you anyway.

comment:3 Changed 9 years ago by anonymous

Resolution: invalid
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain Herbert Valerio Riedel.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.