Modify

Opened 6 years ago

Closed 22 months ago

#8260 closed defect (wontfix)

Browse with 'bare' repository fails

Reported by: Sigurd Hogsbro Owned by: Herbert Valerio Riedel
Priority: high Component: GitPlugin
Severity: critical Keywords: bare repository
Cc: Trac Release: 0.12

Description

When adding a 'bare' repo (as initialized by gitolite post-receive hook), GitPlugin shows an error when 'Browse Source' is clicked.

GitError: read_commit called with empty commit_id

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by Benjamin

Keywords: bare repository added
Priority: normalhigh
Severity: normalcritical

Is there an update on this issue? The only chance I see is to clone the bare repo automatically somewhere else and point to that location.

The issue is e.g. discussed here

http://stackoverflow.com/questions/5183049/trouble-with-a-git-bare-repository-after-upgrading-trac-from-0-11-to-0-12

comment:2 Changed 5 years ago by magon@…

I have problem with bare repositories generated by gitolite. It had the same symptoms but it showed up, that the problem is with file system permissions. I had to change REPO_UMASK of gitolite to '0027' and add 'git' group to apache user.

But your problem seem that you have bare repository and in addition it is completly empty. Adding first commit to it might help.

comment:3 Changed 22 months ago by Ryan J Ollos

Resolution: wontfix
Status: newclosed

GitPlugin is deprecated. Please upgrade to Trac 1.0 and use TracGit.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Herbert Valerio Riedel.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.