Modify

Opened 6 years ago

Closed 6 years ago

#8299 closed defect (fixed)

parentheses in milestone name confuse plugin macros, they show empty content then

Reported by: falkb Owned by: Odd Simon Simonsen
Priority: normal Component: EstimationToolsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description (last modified by Ryan J Ollos)

Give a milestone this name:

S2-DX2 - N3 (test)

Then

[[BurndownChart(milestone=S2-DX2 - N3 (test), startdate=2010-06-11)]]
[[WorkloadChart(milestone=S2-DX2 - N3 (test))]]

remain empty, and

[[HoursRemaining(milestone=S2-DX2 - N3 (test))]]

displays just 0 although I have some tickets for that milestone with remaining hours set.

If I do not use parentheses in the milestone name, everything works well. Spaces in the name are not a problem.

(seen with Bitnami Trac 0.12.1, Native on Windows), EstimationTools-0.4.5-py2.5.egg

Attachments (1)

t8299-query_paranthesis-r10557.diff (2.3 KB) - added by Odd Simon Simonsen 6 years ago.
Unquote parenthesis in query.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 years ago by Ryan J Ollos

Description: modified (diff)

comment:2 Changed 6 years ago by Adrian Fritz

Reproduced. Trac 0.12 on Linux. Tested also with only ( or ).

comment:3 Changed 6 years ago by anonymous

Test details - Error messages

MIlestone Contains WorkloadChart BurndownChart HoursRemaining
"2011-05 (test)" both ( & ) blank blank 0
"(2011-05 test" leading ( blank blank 0
"2011-05 (test" intermediate ( blank blank 0
"2011-05 test)" trailing ) blank blank 0

Looks like the issue is in _calculate_timetable (@ http://trac-hacks.org/browser/estimationtoolsplugin/trunk/estimationtools/burndownchart.py?rev=10082#L144)

comment:4 Changed 6 years ago by Adrian Fritz

sorry, forgot to login

Just a note for my-self: @http://trac-hacks.org/browser/estimationtoolsplugin/trunk/estimationtools/burndownchart.py?rev=10082#L13:

  • from: 'bgcolor': 'ffffff00', 'wecolor':'ccccccaa', 'colorexpected': 'ffddaa', 'weekends':'true', 'gridlines' : '0'}
  • to: 'bgcolor': 'ffffff', 'wecolor':'cccccc', 'colorexpected': 'ffddaa', 'weekends':'true', 'gridlines' : '0'}

comment:5 in reply to:  3 Changed 6 years ago by falkb

Replying to anonymous:

Looks like the issue is in _calculate_timetable (@ http://trac-hacks.org/browser/estimationtoolsplugin/trunk/estimationtools/burndownchart.py?rev=10082#L144)

Maybe http://trac-hacks.org/browser/estimationtoolsplugin/trunk/estimationtools/utils.py#L131 must simply consider "(" and ")" as well. At least it's called by _calculate_timetable

Changed 6 years ago by Odd Simon Simonsen

Unquote parenthesis in query.

comment:6 Changed 6 years ago by Odd Simon Simonsen

Replying to falkb:

Maybe estimationtoolsplugin/trunk/estimationtools/utils.py#L131 must simply consider "(" and ")" as well. At least it's called by _calculate_timetable

That looks to be the correct solution, but please test attachment:t8299-query_paranthesis-r10557.diff

comment:7 in reply to:  6 Changed 6 years ago by anonymous

Replying to osimons:

That looks to be the correct solution, but please test attachment:t8299-query_paranthesis-r10557.diff

Patch works well! Fixed. Thanks very much. :-)

comment:8 Changed 6 years ago by Odd Simon Simonsen

Resolution: fixed
Status: newclosed

(In [10617]) EstimationToolsPlugin: Milestone names with '(' or ')' in them display no data. Need to unquote parenthesis for query arguments. Closes #8299.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Odd Simon Simonsen.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.