Modify

Opened 6 years ago

Closed 4 years ago

#8393 closed defect (duplicate)

Tried to use trac 0.12 with gitplugin failes cause of a Oops: read_commit called with empty commit_id

Reported by: cornbob@… Owned by: Herbert Valerio Riedel
Priority: high Component: GitPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.12

Description (last modified by Ryan J Ollos)

hello,

I got a error everytime I try to use the "browse source code" …

Trac detected an internal error:  GitError:  read_commit called with empty commit_id

Any help would be appreciated.

I looked into the egg, started also a modified one, cause the version for 0.12 was buggy for me. It does not do its job, cause it was complaining about the used git version.

2011-01-11 13:05:18,106 Trac[git_fs] ERROR: GitError: Could not retrieve GIT version (tried to execute/parse '/usr/bin/git-receive-pack --version' but got ValueError('need more than 0 values to unpack',))

So I return true for the version check for git in my modified version of gitplugin, which brought me to the next error (this one here). I've tried and searched, but I did not know, what is the problem with the committer id

today I tried on my host the trac version 0.11 + gitplugin without any problems. (done in 12min)

some infos:

openSUSE 11.2 (x86_64)
git version 1.6.4.2

cheers, chris

Attachments (0)

Change History (7)

comment:1 Changed 6 years ago by anonymous

seems you set git_bin to /usr/bin/git-receive-pack instead of /usr/bin/git

comment:2 in reply to:  1 Changed 6 years ago by cornbob@…

Replying to anonymous:

seems you set git_bin to /usr/bin/git-receive-pack instead of /usr/bin/git

it is set to git_bin = /usr/bin/git

I can post the old trac.ini for debug purposes, pls ask about it

comment:3 Changed 6 years ago by Ryan J Ollos

Description: modified (diff)

comment:4 Changed 6 years ago by chris

Have the same problem but with different call to /usr/lib/git/git-update-ref which is definitely nowhere configured. I have no idea where this is coming from.

I narrowed this down to a call to Storage.git_version which is static function and the parameter for git_bin is handed in wrongly, i.e. the string above. I have not yet figured out who calls it with this parameter and where the acutual value for the parameter originates from. Trying to narrow it down further.

comment:5 Changed 6 years ago by chris

OK, for me the solution was to upgrade to a newer git version. I had 1.6.0.2 installed on a quite dated OpenSuse 11.1. After upgrading to the latest 1.7.4.2 all the issues above went away.

The version check inside PyGIT seems not to be very helpful as my old version passed that.

Hope that helps! Maybe someone can take care of the ticket status.

comment:6 Changed 6 years ago by anonymous

If you have an empty git repo, you receive the following error:

Oops…
Trac detected an internal error:
GitError: read_commit called with empty commit_id
This is probably a local installation issue.

comment:7 in reply to:  description Changed 4 years ago by Jun Omae

Resolution: duplicate
Status: newclosed

2011-01-11 13:05:18,106 Trac[git_fs] ERROR: GitError: Could not retrieve GIT version (tried to execute/parse '/usr/bin/git-receive-pack --version' but got ValueError('need more than 0 values to unpack',))

A duplicate of #8682.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Herbert Valerio Riedel.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.