Modify

Opened 6 years ago

Closed 15 months ago

#8465 closed defect (wontfix)

Trac[git_fs] ERROR: GitError: Could not retrieve GIT version

Reported by: anonymous Owned by: hvr
Priority: normal Component: GitPlugin
Severity: blocker Keywords:
Cc: bsavelev, stuge Trac Release: 0.12

Description

Hi, all! I have a problem with my trac-and-git. I got error "

Warning: Can't synchronise with repository "(default)" (GIT backend not available). Look in the Trac log for more information."

And in logs

Trac[git_fs] ERROR: GitError: Could not retrieve GIT version.

My config:

[git]
cached_repository = false 
persistent_cache = false
shortrev_len = 7
git = /usr/bin/git

If I write git_bin instead - another error occurs

TypeError: 'NoneType' object is unsubscriptable

and in logs we have:

Traceback (most recent call last):
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 513, in _dispatch_request
    dispatcher.dispatch(req)
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 200, in dispatch
    chosen_handler)
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 346, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/api.py", line 330, in pre_process_request
    repo = self.get_repository(reponame)
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/api.py", line 526, in get_repository
    repos = connector.get_repository(rtype, rdir, repoinfo.copy())
  File "/usr/lib/python2.5/site-packages/tracext/git/git_fs.py", line 159, in get_repository
    shortrev_len=self._shortrev_len)
  File "/usr/lib/python2.5/site-packages/tracext/git/git_fs.py", line 177, in __init__
    Repository.__init__(self, "git:"+path, None, log)
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/api.py", line 730, in __init__
    self.reponame = params['name']
TypeError: 'NoneType' object is unsubscriptable

I found similar decisions of this trouble, but not for 0.12 version.

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by bsavelev

  • Cc bsavelev added; anonymous removed
  • Severity changed from normal to blocker

also sa #8519

I have the same issue

comment:2 Changed 5 years ago by mgarraha

May be caused by #8682.

comment:3 Changed 5 years ago by anonymous

I resolve my problem with restarting fastcgi trac process sometimes. I don't know what it was

comment:4 Changed 4 years ago by leskop@…

I can confirm this issue. I'm getting same message on Windows 7 64bit. Using BitNami Trac with tracgit 0.12.0.5dev plugin

comment:5 Changed 4 years ago by stuge

  • Cc stuge added

comment:6 Changed 15 months ago by rjollos

  • Resolution set to wontfix
  • Status changed from new to closed

GitPlugin is deprecated. Please upgrade to Trac 1.0 and use TracGit.

Add Comment

Modify Ticket

Action
as closed The owner will remain hvr.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.