Modify

Opened 6 years ago

Closed 5 years ago

#8475 closed defect (duplicate)

Problems on trac 0.12?

Reported by: ivoras@… Owned by: Robert Corsaro
Priority: high Component: AnnouncerPlugin
Severity: major Keywords:
Cc: Trac Release: 0.12

Description (last modified by Ryan J Ollos)

The link for AnnouncerPlugin for Trac 0.12 doesn't work so I've downloaded from trunk. Immediately after installation there was a problem with tables not being created in the trac database (and a request for running trac-admin ... upgrade which did nothing and reported that it doesn't need upgrading).

I've created the tables from looking at the code of the plugins (tables subscription and subscription_attribute from SCHEMA in api.py) and that apparently worked, except e-mails for wiki changes are not sent at all.

A DEBUG info in trac logs says:

2011-02-07 13:03:59,818 Trac[api] DEBUG: AnnouncementSystem has found the following subscriptions: 
2011-02-07 13:03:59,819 Trac[api] DEBUG: AnnouncementSystem sent event in 0.01 seconds.

... even though I am subscribed to the page, as seen in the database:

sqlite> select * from subscription_attribute;
1|ivoras|1|WatchSubscriber|wiki|WikiStart
2|ivoras|1|WatchSubscriber|wiki|TracMain

My trac.ini contains:

[announcer]
email_address_resolvers = SpecifiedEmailResolver, SessionEmailResolver
email_enabled = true
email_from = some@example.com
email_sender = SmtpEmailSender
email_replyto = trac@example.com
mime_encoding = base64
use_public_cc = false
email_subject_prefix = __default__
email_to = undisclosed-recipients: ;
use_threaded_delivery = false
default_email_format = text/plain

[components]
announcer.api.announcementsystem = enabled
announcer.api.subscriptionresolver = enabled
announcer.distributors.mail.emaildistributor = enabled
announcer.distributors.mail.sendmailemailsender = enabled
announcer.distributors.mail.smtpemailsender = enabled
announcer.email_decorators.announceremaildecorator = enabled
announcer.email_decorators.staticemaildecorator = enabled
announcer.email_decorators.threadingemaildecorator = enabled
announcer.email_decorators.ticketaddlheaderemaildecorator = enabled
announcer.email_decorators.ticketsubjectemaildecorator = enabled
announcer.email_decorators.wikisubjectemaildecorator = enabled
announcer.filters.defaultpermissionfilter = enabled
announcer.formatters.ticketformatter = enabled
announcer.formatters.wikiformatter = enabled
announcer.pref.announcerpreferences = enabled
announcer.pref.subscriptionmanagementpanel = enabled
announcer.producers.attachmentchangeproducer = enabled
announcer.producers.ticketchangeproducer = enabled
announcer.producers.wikichangeproducer = enabled
announcer.resolvers.defaultdomainemailresolver = enabled
announcer.resolvers.sessionemailresolver = enabled
announcer.resolvers.specifiedemailresolver = enabled
announcer.subscribers.allticketsubscriber = enabled
announcer.subscribers.carboncopysubscriber = enabled
announcer.subscribers.generalwikisubscriber = enabled
announcer.subscribers.joinablegroupsubscriber = enabled
announcer.subscribers.ticketcomponentownersubscriber = enabled
announcer.subscribers.ticketcomponentsubscriber = enabled
announcer.subscribers.ticketcustomfieldsubscriber = enabled
announcer.subscribers.ticketownersubscriber = enabled
announcer.subscribers.ticketreportersubscriber = enabled
announcer.subscribers.ticketupdatersubscriber = enabled
announcer.subscribers.userchangesubscriber = enabled
announcer.subscribers.watchsubscriber = enabled

[smtp]
port = 25
server = localhost

In short - is there a version that works with Trac 0.12?

Attachments (0)

Change History (2)

comment:1 in reply to:  description Changed 6 years ago by Dmitri

Replying to ivoras@gmail.com:

In short - is there a version that works with Trac 0.12?

I'm successfully using 0.11.2dev on trac-0.12.2.

comment:2 Changed 5 years ago by Ryan J Ollos

Description: modified (diff)
Resolution: duplicate
Status: newclosed

I think your problem is tracked in #9742. Please track that ticket, and once the issue is fixed, drop your tables and reinstall.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Robert Corsaro.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.