Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#8672 closed defect (fixed)

Installation problem on Trac 0.11 and MySQL

Reported by: Roberto Longobardi Owned by: Roberto Longobardi
Priority: normal Component: TestManagerForTracPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11


Reporting a mail thread here as a ticket, for reference to other users.



I hope you don't mind me asking, not creating a ticket (checked them, there was one simillar to my problem), but have you seen anything like this?

Trac 0.11.5 with MySql Server version: 5.1.41-3ubuntu12.10 (Ubuntu)

trac-admin /trac/trac upgrade
Traceback (most recent call last):
 File "/usr/local/bin/trac-admin", line 9, in <module>
   load_entry_point('Trac==0.11.5', 'console_scripts', 'trac-admin')()
 File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.5-py2.6.egg/trac/admin/", line 1314, in run
   return admin.onecmd(command)
 File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.5-py2.6.egg/trac/admin/", line 133, in onecmd
   rv = cmd.Cmd.onecmd(self, line) or 0
 File "/usr/lib/python2.6/", line 219, in onecmd
   return func(arg)
 File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.5-py2.6.egg/trac/admin/", line 1154, in do_upgrade
 File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.5-py2.6.egg/trac/", line 457, in upgrade
 File "/trac/trac/plugins/TestManager-1.4.4-py2.6.egg/testmanager/", line 638, in upgrade_environment
 File "/trac/trac/plugins/TracGenericClass-1.0.4-py2.6.egg/tracgenericclass/", line 1276, in upgrade_db
 File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.5-py2.6.egg/trac/db/", line 60, in execute
   return self.cursor.execute(sql)
 File "/usr/lib/pymodules/python2.6/MySQLdb/", line 166, in execute
   self.errorhandler(self, exc, value)
 File "/usr/lib/pymodules/python2.6/MySQLdb/", line 35, in defaulterrorhandler
   raise errorclass, errorvalue
_mysql_exceptions.ProgrammingError: (1064, "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'int64,\n    PRIMARY KEY (`id`(255))\n)' at line 7")

Sorry to ask, but my knowledge about python is very limited and this is my first attemt to install a plugin into Trac. I did manage to solve some issues as it stated for example that the TracXMLRPC was missing...

added this->TracXMLRPC.* = enabled
estimationtools.* = enabled
timingandestimationplugin.* = enabled
timingandestimationplugin.stopwatch.ticketstopwatch = disabled
timingandestimationplugin.tande_filters.timeclickfilter = disabled
timingandestimationplugin.tande_filters.totalhoursfilter = enabled
timingandestimationplugin.webui.timingestimationandbillingpage = disabled
added this->TracGenericClass.* = enabled
added this->TracGenericWorkflow.* = enabled
added this->TestManager.* = enabled

it will start just fine if I disable the TestManager and the ugrade(s) before enabling that went fine without problems

I marked the modifications my 'added this->'

For me it seems like the database modifications won't go through and neither will any trac.ini modifications for the TestManager trac-admin upgrade.

I will try to install this into a Ubuntu virtual box during the weekend, but if you have seen anything like this and are able to spot something I'm missing the help is greatly appreciated.

Attachments (0)

Change History (2)

comment:1 Changed 13 years ago by Roberto Longobardi

I have been reported a similar problem with PosgreSQL some days ago, and I drilled it down to being the Trac 0.11 support for the specific database not being able to handle int64 column types. I asked the guy to upgrade to Trac 0.12.2, and this actually solved the problem.

I'm seeing in your trace log a similar message:

_mysql_exceptions.ProgrammingError: (1064, "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near

    PRIMARY KEY (`id`(255))
)' at line 7")

so it may just be the same problem.

Please, could you make a try and install Trac 0.12 (in case using virtualenv, a very useful utility that lets you install another "user local" Trac environment without disturbing the main shared system-wide Trac installation) and see if you have the same problem with your current MySQL configuration?

comment:2 Changed 13 years ago by Roberto Longobardi

Resolution: fixed
Status: newclosed

I actually tried the upgrading to 12.stable already yesterday :) it did work, so it seems to be a 11.5 specific problem.

At the moment I'm verifying that all the content is fine on the sandboxed copy that I upgraded and we can upgrade the production Trac too.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain Roberto Longobardi.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.