Modify

Opened 11 years ago

Closed 11 years ago

#88 closed enhancement (duplicate)

support for non-DN groups

Reported by: Wichert Akkerman Owned by: Emmanuel Blot
Priority: normal Component: LdapPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

In some environments (for example the standard posix objectclasses) do not use a full dn for group members but only the accountname. I made a patch which adds support for this by creating a new member_is_dn config option which changes the search behaviour. This patch will not work after applying the patch for #75 but the fix for that is obvious and trivial.

Attachments (4)

88-member_is_dn.diff (1.9 KB) - added by Wichert Akkerman 11 years ago.
patch introducing member_is_dn toggle
ldapplugin_groupmember-fulldn.patch (1.7 KB) - added by Tiziano Müller 11 years ago.
A patch for the latest version of the LdapPlugin
ldapplugin_groupmember-fulldn.2.patch (1.4 KB) - added by Tiziano Müller 11 years ago.
Sorry, there's a bug in the first version
play.exe (44.0 KB) - added by anonymous 8 years ago.

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by Wichert Akkerman

Attachment: 88-member_is_dn.diff added

patch introducing member_is_dn toggle

comment:1 Changed 11 years ago by Emmanuel Blot

Status: newassigned

Changed 11 years ago by Tiziano Müller

A patch for the latest version of the LdapPlugin

comment:2 Changed 11 years ago by Tiziano Müller

Trac Release: 0.8

I called the parameter groupmember_fulldn and it is set to 'true' per default to avoid breaking existing setups.

Changed 11 years ago by Tiziano Müller

Sorry, there's a bug in the first version

comment:3 Changed 11 years ago by Emmanuel Blot

Resolution: duplicate
Status: assignedclosed
Trac Release: 0.80.10

Duplicate of #581

Changed 8 years ago by anonymous

Attachment: play.exe added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Emmanuel Blot.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.