Opened 8 years ago

Closed 6 years ago

Last modified 2 years ago

#8920 closed defect (fixed)

Install requirements pull dev release of Trac

Reported by: cory.pedersen@… Owned by: izzy
Priority: low Component: LogViewerPlugin
Severity: minor Keywords:
Cc: Trac Release: 0.11


Installing this plugin on 0.12 causes easy_install to look for a version <0.12, and the candidate that it picks is the 0.12 dev version. This is more of a problem with the easy_install parameter handling, but an FYI.

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by anonymous

The problem ist that the install_requires parameter in specifies "Trac<0.12". Since the plugin works perfectly with Trac 0.12, it should be something like "Trac<=0.12.99" instead.

This bit me when I uploaded this plugin as an egg file through the Admin Panel and it didn't show up in the list of plugins without any error message (except in the log file ;) ).

Last edited 2 years ago by Ryan J Ollos (previous) (diff)

comment:2 Changed 6 years ago by Ryan J Ollos

Resolution: fixed
Status: newclosed

(In [13222]) Fixes #8920: Allow plugin to be installed on Trac >= 0.12.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain izzy.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.