Modify

Opened 6 years ago

Closed 6 years ago

#8988 closed defect (fixed)

Task timelines don't span the due date

Reported by: Ryan J Ollos Owned by: Chris Nelson
Priority: normal Component: TracJsGanttPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

I think this is a defect, though it could be by design. If I have a task that spans 2 days, say 07/14 and 07/15, it is only shown in the Gantt chart as spanning 07/14. Also, a tasks with equal start and end dates doesn't span that one day.

The task in the first circle should span 1 day. The task in the second circle should span two days.

I ran into a similar issue and implemented a patch for Trac a while back (t:#9582). The issue was that a milestone became overdue at 12:01 am on it's due date. The patch made the milestone overdue at 6:01 pm on the due date.

I can submit a fix for this over the coming weekend.

Attachments (1)

TasksDontSpanDueDate.png (17.0 KB) - added by Ryan J Ollos 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Ryan J Ollos

Attachment: TasksDontSpanDueDate.png added

comment:1 in reply to:  description ; Changed 6 years ago by Chris Nelson

Status: newassigned

Replying to rjollos:

I think this is a defect, though it could be by design. If I have a task that spans 2 days, say 07/14 and 07/15, it is only shown in the Gantt chart as spanning 07/14. Also, a tasks with equal start and end dates doesn't span that one day.

We fixed this locally and I thought we'd merged our development branch to the TH branch. I can look into it.

... I can submit a fix for this over the coming weekend.

IMHO, this is a rendering issue and needs to be solved in the presentation (JavaScript) layer. That's what we did.

comment:2 in reply to:  1 Changed 6 years ago by Ryan J Ollos

Replying to ChrisNelson:

We fixed this locally and I thought we'd merged our development branch to the TH branch. I can look into it.

I'm still running version 0.7 of the plugin and haven't looked at what went into version 0.8. I'll upgrade today and report back.

comment:3 Changed 6 years ago by Ryan J Ollos

I'm running 0.8 now and still see this issue. Thanks for looking into this!

comment:4 Changed 6 years ago by Chris Nelson

(In [10474]) Extended width of tasks by 1 box. Refs #8988.

comment:5 Changed 6 years ago by Ryan J Ollos

Resolution: fixed
Status: assignedclosed

This is resolved for me now. Thanks!

Modify Ticket

Action
as closed The owner will remain Chris Nelson.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.