Modify

Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#9036 closed defect (duplicate)

TracDiscussion 0.8-r9877 does not work wih TracSpamFilter 0.4.7dev-r10756

Reported by: diddek Owned by: Radek Bartoň
Priority: normal Component: DiscussionPlugin
Severity: major Keywords:
Cc: Trac Release: 0.12

Description (last modified by Ryan J Ollos)

I believe both are the latest versions, but I get this:

Oops…
Trac detected an internal error:
TypeError: test() takes exactly 5 arguments (4 given)
There was an internal error in Trac. It is recommended that you notify your local Trac administrator with the information needed to reproduce the issue.

To that end, you could   a ticket.

The action that triggered the error was:

POST: /discussion/forum/2

Attachments (0)

Change History (5)

comment:1 Changed 11 years ago by diddek

From the spamfilter test (http://trac.edgewall.org/browser//plugins/0.12/spam-filter-captcha/tracspamfilter/tests/api.py) I understood the call to FilterSystem in tracdiscussion/spamfilter.py needed an ip adress:

FilterSystem(self.env).test(req, '', [], '127.0.0.1')

I added my ip address and now it works again, but maybe this could/needs to be fixed in tracdiscussion?

Best, D

comment:2 Changed 11 years ago by anonymous

In usr/local/lib/python2.7/dist-packages/TracDiscussion-0.8_r9877-py2.7.egg/tracdiscussion/spamfilter.py: 23

change

FilterSystem(self.env).test(context.req, topic['author'], [(None,topic['author']), (None, topic['subject']), (None, topic['body'])])

into

FilterSystem(self.env).test(context.req, topic['author'], [(None, topic['author']), (None, topic['subject']), (None, topic['body'])], '127.0.0.1')

comment:3 Changed 10 years ago by Ryan J Ollos

Description: modified (diff)

comment:4 Changed 10 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #8764.

comment:5 Changed 10 years ago by Ryan J Ollos

Fixed in [12058].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Radek Bartoň.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.