Modify

Opened 6 years ago

Closed 6 years ago

#9043 closed defect (fixed)

TranslatedPagesMacro can't work with 0.12?

Reported by: jeanvixue@… Owned by: Zhang Cong
Priority: normal Component: TranslatedPagesMacro
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

I install it with trac 0.12 successfully. But when I put the macro in the pages, why no language index box show? I had create the wiki page start with Langauage code such like, Zh_CN:xxx, En:xx. But in the pages xx, nothing happens. Do you have any clue?

As you mentioned, is page named TracLanguages must be exists? If so, how to make first line of the table start with
don't be parsed.

waiting for you help, thanks in advance.

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by Dirk Stöcker

Resolution: fixed
Status: newclosed

The language box only shows when at least 2 pages exist and the language definition is correct.

So you need the TracLanguages page in any case. Simply copy it, it automatically ignores the header lines and it will also display them correctly on 0.12. It looks only ugly here on this ancient 0.10 installation.

comment:2 Changed 6 years ago by Dirk Stöcker

P.S. Adding [[TranslatedPages(showproblems)]] to any page and then previewing (no need to save) should tell you what's wrong.

comment:3 Changed 6 years ago by Dirk Stöcker

In [10515] I added a check telling you whether language specification page is correct or not.

comment:4 in reply to:  2 ; Changed 6 years ago by anonymous

Resolution: fixed
Status: closedreopened

Replying to stoecker:

P.S. Adding [[TranslatedPages(showproblems)]] to any page and then previewing (no need to save) should tell you what's wrong.

how to handle "Base language is missing for translated pages "? thanks.

comment:5 in reply to:  4 ; Changed 6 years ago by anonymous

Replying to anonymous:

Replying to stoecker:

P.S. Adding [[TranslatedPages(showproblems)]] to any page and then previewing (no need to save) should tell you what's wrong.

I had add parameter showproblems to show the error message. And there is no error(only show none). But I still can't see the Language index box show in the page. Any others clues? thanks

comment:6 in reply to:  5 Changed 6 years ago by anonymous

Resolution: fixed
Status: reopenedclosed

Replying to anonymous:

Replying to anonymous:

Replying to stoecker:

P.S. Adding [[TranslatedPages(showproblems)]] to any page and then previewing (no need to save) should tell you what's wrong.

Resolved. sorry for inconvenience. showproblems parament will result in no language box show in the page

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Zhang Cong.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.