Modify

Opened 6 years ago

Closed 5 years ago

#9247 closed defect (duplicate)

Cast authenticated values to int

Reported by: Eygene Ryabinkin Owned by: Robert Corsaro
Priority: high Component: AnnouncerPlugin
Severity: critical Keywords:
Cc: Trac Release: 0.12

Description

After upgrade to the lastest /trunk contents (r10743) my PostgreSQL server spitted an error about comparison of the subscription_attribute.authenticated with the boolean value and the problematic code was inside announcer/model.py.

Seems like model.py has the old code from pre-int era for the authenticated field.

The patch at http://codelabs.ru/fbsd/ports/trac-announcer/authenticated-int-cast.diff fixes the problem for me.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by Eygene Ryabinkin

Hi! Can this patch be reviewed?

Thanks.

comment:2 Changed 5 years ago by Eygene Ryabinkin

Anyone?

comment:3 Changed 5 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #10384, which has a patch attached to the ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Robert Corsaro.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.