Modify

Opened 5 years ago

Closed 4 years ago

#9296 closed enhancement (duplicate)

Please, consider following patch for Trac 0.12

Reported by: abondar@… Owned by: Ryan J Ollos
Priority: normal Component: TracTicketStatsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

It optimizes SQL requests

Attachments (1)

ticketstats.py.patch (3.2 KB) - added by anonymous 5 years ago.

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by anonymous

Attachment: ticketstats.py.patch added

comment:1 Changed 4 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

We do need to optimize the queries, however I'm not sure that your patch gets it quite right. Your patch appears to query the database and retrieve the current status of each ticket, only putting restrictions on the creation time. Rather, we need to look at the ticket_change table to determine the number of opened and closed tickets on a particular date.

I will close this as a duplicate of #7001 and commit a patch against that ticket. Please track the changes and test if you are able.

Modify Ticket

Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.