Modify

Opened 5 years ago

Closed 5 years ago

#9654 closed defect (fixed)

Error when creating test plans

Reported by: anonymous Owned by: Roberto Longobardi
Priority: normal Component: TestManagerForTracPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description (last modified by Ryan J Ollos)

Running version 1.4.8 and Trac 0.12. Catalogs and Test Cases can be created fine with no errors. However whenever a Test Plan is created, the Plan creation works, but after that, anytime I try to view the Catalog that its associated with, I get the following error:

ParseError: malformed start tag: line 1, column 801

I'm currently working around this by commenting out line 247 in wiki.py

self._get_testplan_list_markup(formatter, cat_name, mode, fulldetails)

as the problem appears to be with this function but then I can see the Catalog but not any of its Test Plans.

Attachments (2)

log.zip (3.9 KB) - added by anonymous 5 years ago.
testman4trac.1.4.9.src.PATCHED.zip (13.0 KB) - added by Roberto Longobardi 5 years ago.
Patched wiki.py and utils.py

Download all attachments as: .zip

Change History (13)

comment:1 Changed 5 years ago by Ryan J Ollos

Description: modified (diff)

comment:2 Changed 5 years ago by Roberto Longobardi

Hi, this problem is new to me... I didn't get it while testing out the 1.4.8 release.

I'll take a look at this asap.

Ciao, Roberto

comment:3 Changed 5 years ago by Roberto Longobardi

Hi, the fix to this ticket is in the latest BETA 1.4.9 release, attached to #9287.

Actually there also is the need for updating the language catalogs. I have uploaded the modified versions on Transflex for anyone to contribute.

Refer to the forum post for details.

It would be great if you could take a tour and, besides looking at the new stuff, make sure nothing (big) is broken.

Thanks, ciao. Roberto

comment:4 Changed 5 years ago by anonymous

I reported this issue originally and have done an SVN checkout to get version 1.4.9. After installing and testing by creating a new test plan in a Catalog, I am still getting a similar error,

ParseError: malformed start tag: line 1, column 812

comment:5 Changed 5 years ago by Roberto Longobardi

Hi, please could you enable debug in your Trac and attach the full log file, including the startup section where Trac dumps detailed information about your environment.

Also, would you please describe it briefly here:

  • Operating system and version
  • Python version
  • Trac version
  • ...anything else that comes to your mind :D

Ciao, Roberto

comment:6 Changed 5 years ago by Roberto Longobardi

  • DB type and version
  • Whether you use Apache or tracd

comment:7 Changed 5 years ago by anonymous

OS = Linux 2.6, Python = 2.6, Trac = 0.12, DB = SQLite, using tracd, debug log is attached.

Changed 5 years ago by anonymous

Attachment: log.zip added

comment:8 Changed 5 years ago by Roberto Longobardi

The problem seems related to the fcat that you have your email address specified in your preferences:

Jake Westfall <jake@jpw.biz>

The angular brackets are not escaped and cause problems to the Genshi code parsing the HTML.

I'll try to fix it asap.

Changed 5 years ago by Roberto Longobardi

Patched wiki.py and utils.py

comment:9 Changed 5 years ago by Roberto Longobardi

Status: newassigned

Try the attached source code. Replace on top of 1.4.9.

BTW, I also released the zip files on source forge (with this fix).

Please, let me know if this fixes the problem (and close this ticket).

comment:10 Changed 5 years ago by anonymous

Yes, confirming that the problem is fixed.

comment:11 Changed 5 years ago by anonymous

Resolution: fixed
Status: assignedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Roberto Longobardi.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.