Modify

Opened 5 years ago

Closed 5 years ago

#9658 closed defect (duplicate)

WindowsError: (5, 'Access is denied')

Reported by: LUG-BRZ\rfernandez Owned by: Herbert Valerio Riedel
Priority: highest Component: GitPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.12

Description

How to Reproduce

While doing a GET operation on /changeset/eac625266359cce9f7d3128d02d78a67412b8b8e/, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'format': u'diff',
 'new': u'eac625266359cce9f7d3128d02d78a67412b8b8e',
 'new_path': u'/'}

User agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.63 Safari/535.7

System Information

Trac 0.12
Agilo 0.9.5
Genshi 0.6
GIT 1.7.8.msysgit.0
mod_python 3.3.2-dev-20080819
pysqlite 2.4.1
Python 2.6.4 (r264:75708, Oct 26 2009, 08:23:19) [MSC v.1500 32 bit (Intel)]
setuptools 0.6c11
SQLite 3.5.9
Subversion 1.6.2 (r37639)
jQuery 1.4.2

Enabled Plugins

agilo 0.9.5
tracaccountmanager 0.3dev-r10294
tracgit 0.12.0.5dev

Python Traceback

Traceback (most recent call last):
  File "c:\docume~1\rferna~1\locals~1\temp\1\easy_install-fesswe\Trac-0.12-py2.6-win32.egg.tmp\trac\web\main.py", line 513, in _dispatch_request
    dispatcher.dispatch(req)
  File "c:\docume~1\rferna~1\locals~1\temp\1\easy_install-fesswe\Trac-0.12-py2.6-win32.egg.tmp\trac\web\main.py", line 235, in dispatch
    resp = chosen_handler.process_request(req)
  File "c:\docume~1\rferna~1\locals~1\temp\1\easy_install-fesswe\Trac-0.12-py2.6-win32.egg.tmp\trac\versioncontrol\web_ui\changeset.py", line 347, in process_request
    self._render_diff(req, filename, repos, data)
  File "c:\docume~1\rferna~1\locals~1\temp\1\easy_install-fesswe\Trac-0.12-py2.6-win32.egg.tmp\trac\versioncontrol\web_ui\changeset.py", line 689, in _render_diff
    old_path=data['old_path'], old_rev=data['old_rev']):
  File "build\bdist.win32\egg\tracext\git\git_fs.py", line 434, in get_changes
    yield old_node, new_node, kind, change
  File "C:\Python26\Lib\contextlib.py", line 23, in __exit__
    self.gen.next()
  File "build\bdist.win32\egg\tracext\git\PyGIT.py", line 760, in get_historian
    p[0].terminate()
  File "C:\Python26\Lib\subprocess.py", line 937, in terminate
    TerminateProcess(self._handle, 1)
WindowsError: [Error 5] Access is denied

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Ryan J Ollos

Component: SELECT A HACKGitPlugin
Owner: changed from anonymous to Herbert Valerio Riedel

Assuming this is for the GitPlugin.

comment:2 Changed 5 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #9646.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Herbert Valerio Riedel.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.