Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9755 closed enhancement (duplicate)

Populate user preferences with name and email

Reported by: Ryan J Ollos Owned by: Steffen Hoffmann
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords: user attribute management
Cc: Trac Release: 0.12

Description (last modified by Ryan J Ollos)

The Add/Edit Account section on the Administration > Accounts > Users panel has fields for the user's name and email address, but these fields don't seem to be populating the same table that populates the Preferences > General panel. Looking at the Trac database schema, I don't see where these are stored, but either way it seems desirable to allow the user to change their name and email from the Preferences > General panel.

Does this make any sense to do?

Attachments (2)

AddEditAccountPanel.png (14.1 KB) - added by Ryan J Ollos 5 years ago.
PreferencesGeneralPanel.png (12.7 KB) - added by Ryan J Ollos 5 years ago.

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by Ryan J Ollos

Attachment: AddEditAccountPanel.png added

Changed 5 years ago by Ryan J Ollos

Attachment: PreferencesGeneralPanel.png added

comment:1 Changed 5 years ago by Ryan J Ollos

Description: modified (diff)

comment:2 in reply to:  description ; Changed 5 years ago by Steffen Hoffmann

Keywords: user attribute management added

Replying to rjollos:

The Add/Edit Account section on the Administration > Accounts > Users panel has fields for the user's name and email address, but these fields don't seem to be populating the same table that populates the Preferences > General panel.

No? What else? Since there is no real concept of users the values are all folded and added with the corresponding sid = username as key-value-pairs into session_attribute db table.

Looking at the Trac database schema, I don't see where these are stored, but either way it seems desirable to allow the user to change their name and email from the Preferences > General panel.

Does this make any sense to do?

Yes, and it is known to work already exactly this way. Admin can change for all sid's/users, users only for their own sid.

comment:3 in reply to:  2 Changed 5 years ago by Ryan J Ollos

Replying to hasienda:

Yes, and it is known to work already exactly this way. Admin can change for all sid's/users, users only for their own sid.

After I create a user from the Admin panel (entering their name and email in the corresponding fields), I log in as that user, navigate to preferences panel, and find that the name and email fields are blank. If you say that the fields should be populated, then I'll setup and try to reproduce in a dev environment, where I have the tools to more easily look at the database and step through the code.

comment:4 Changed 5 years ago by Steffen Hoffmann

I see. Test with existing users - works just fine.

For new users there is a known issue with trunk, and you'll want to track #9252. I know, the summary there is far from optimal.

comment:5 Changed 5 years ago by Ryan J Ollos

So it looks like maybe this ticket should get closed as duplicate of #9252.

comment:6 Changed 5 years ago by Steffen Hoffmann

Resolution: duplicate
Status: newclosed

Sure, I just wanted to suggest this not too soon, to possibly see something else behind.

comment:7 Changed 5 years ago by Ryan J Ollos

I'll keep my eye on #9252. Thanks for your help, once again!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.