Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#980 closed defect (duplicate)

Charset Encoding and Problems

Reported by: dh1jc Owned by: Alec Thomas
Priority: low Component: PageToPdfPlugin
Severity: minor Keywords: charset encoding
Cc: Trac Release: 0.10

Description

Short notice on Charset encoding.

I changed from ISO Charset to UTF-8, because of some pages can't be rendered (converted) into ISO (see below).

Example Page: TrakTickets (or other Help Pages)

Traceback (most recent call last):
  File "/var/lib/python-support/python2.4/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/var/lib/python-support/python2.4/trac/web/main.py", line 238, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/tractags/web_ui.py", line 64, in process_request
  File "/var/lib/python-support/python2.4/trac/wiki/web_ui.py", line 134, in process_request
    page.text, format, page.name)
  File "/var/lib/python-support/python2.4/trac/mimeview/api.py", line 604, in send_converted
    content, selector)
  File "/var/lib/python-support/python2.4/trac/mimeview/api.py", line 384, in convert_content
    output = converter.convert_content(req, mimetype, content, ck)
  File "build/bdist.linux-i686/egg/pagetopdf/pagetopdf.py", line 20, in convert_content
  File "encodings/iso8859_15.py", line 18, in encode
UnicodeEncodeError: 'charmap' codec can't encode character u'\u201c' in position 8595: character maps to <undefined>

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by Noah Kantrowitz

Resolution: duplicate
Status: newclosed

See this comment. You will have to remove the offending characters from the page.

Duplicate of #897.

comment:2 Changed 10 years ago by dh1jc

;) but the conversion should do that automatically!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Alec Thomas.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.