Modify

Opened 5 years ago

Closed 18 months ago

#9929 closed defect (duplicate)

Gannt Calender fails when depgrap.web_ui is enabled.

Reported by: prasad.kulkarnin@… Owned by: ftiede
Priority: normal Component: TracTicketDepgraphPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description (last modified by rjollos)

Traceback (most recent call last):
  File "build/bdist.linux-i686/egg/trac/web/api.py", line 441, in send_error
    data, 'text/html')
  File "build/bdist.linux-i686/egg/trac/web/chrome.py", line 870, in render_template
    encoding='utf-8')
  File "build/bdist.linux-i686/egg/genshi/core.py", line 183, in render
    return encode(generator, method=method, encoding=encoding, out=out)
  File "build/bdist.linux-i686/egg/genshi/output.py", line 58, in encode
    for chunk in iterator:
  File "build/bdist.linux-i686/egg/genshi/output.py", line 339, in __call__
    for kind, data, pos in stream:
  File "build/bdist.linux-i686/egg/genshi/output.py", line 826, in __call__
    for kind, data, pos in stream:
  File "build/bdist.linux-i686/egg/genshi/output.py", line 670, in __call__
    for kind, data, pos in stream:
  File "build/bdist.linux-i686/egg/genshi/output.py", line 771, in __call__
    for kind, data, pos in chain(stream, [(None, None, None)]):
  File "build/bdist.linux-i686/egg/genshi/output.py", line 586, in __call__
    for ev in stream:
  File "build/bdist.linux-i686/egg/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "build/bdist.linux-i686/egg/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "build/bdist.linux-i686/egg/trac/web/chrome.py", line 984, in _strip_accesskeys
    for kind, data, pos in stream:
  File "build/bdist.linux-i686/egg/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "build/bdist.linux-i686/egg/trac/web/chrome.py", line 973, in _generate
    for kind, data, pos in stream:
  File "build/bdist.linux-i686/egg/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "build/bdist.linux-i686/egg/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "build/bdist.linux-i686/egg/genshi/filters/transform.py", line 686, in _unmark
    for mark, event in stream:
  File "build/bdist.linux-i686/egg/timingandestimationplugin/tande_filters.py", line 95, in __call__
    for mark, event in stream:
  File "build/bdist.linux-i686/egg/genshi/filters/transform.py", line 714, in __call__
    for mark, event in stream:
  File "build/bdist.linux-i686/egg/genshi/filters/transform.py", line 682, in _mark
    for event in stream:
  File "build/bdist.linux-i686/egg/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "build/bdist.linux-i686/egg/genshi/filters/transform.py", line 686, in _unmark
    for mark, event in stream:
  File "build/bdist.linux-i686/egg/timingandestimationplugin/tande_filters.py", line 95, in __call__
    for mark, event in stream:
  File "build/bdist.linux-i686/egg/genshi/filters/transform.py", line 714, in __call__
    for mark, event in stream:
  File "build/bdist.linux-i686/egg/genshi/filters/transform.py", line 682, in _mark
    for event in stream:
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 605, in _include
    for event in stream:
  File "build/bdist.linux-i686/egg/genshi/template/markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "build/bdist.linux-i686/egg/genshi/template/markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "build/bdist.linux-i686/egg/genshi/template/markup.py", line 327, in _match
    for event in stream:
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 545, in _flatten
    for kind, data, pos in stream:
  File "build/bdist.linux-i686/egg/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "build/bdist.linux-i686/egg/genshi/path.py", line 588, in _generate
    subevent = next()
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 605, in _include
    for event in stream:
  File "build/bdist.linux-i686/egg/genshi/template/markup.py", line 316, in _strip
    event = next()
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 545, in _flatten
    for kind, data, pos in stream:
  File "build/bdist.linux-i686/egg/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "build/bdist.linux-i686/egg/genshi/path.py", line 588, in _generate
    subevent = next()
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 605, in _include
    for event in stream:
  File "build/bdist.linux-i686/egg/genshi/template/markup.py", line 316, in _strip
    event = next()
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 565, in _flatten
    result = _eval_expr(data, ctxt, vars)
  File "build/bdist.linux-i686/egg/genshi/template/base.py", line 277, in _eval_expr
    retval = expr.evaluate(ctxt)
  File "build/bdist.linux-i686/egg/genshi/template/eval.py", line 178, in evaluate
    return eval(self.code, _globals, {'__data__': data})
  File "/root/.python-eggs/Trac-0.12.3-py2.6.egg-tmp/trac/templates/error.html", line 165, in <Expression u'shorten_line(repr(value))'>
    <td><code>${shorten_line(repr(value))}</code></td>
  File "build/bdist.linux-i686/egg/mastertickets/model.py", line 118, in __repr__
    (self.tkt.id, l(getattr(self, 'blocking', [])), l(getattr(self, 'blocked_by', [])))
AttributeError: 'TicketLinks' object has no attribute 'tkt'

Attachments (0)

Change History (2)

comment:1 Changed 18 months ago by rjollos

  • Description modified (diff)

comment:2 Changed 18 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9851.

Add Comment

Modify Ticket

Action
as closed The owner will remain ftiede.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.