Modify

Opened 6 years ago

Closed 9 months ago

#9957 closed defect (worksforme)

traccmd.py from within bash script does not work

Reported by: anonymous Owned by: Nic Ferrier
Priority: normal Component: TracCmdScript
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

I con not create ticket from bash script like this

 TRACCMD_CMD = `which TRACCMD_CMD`
 $TRACCMD_CMD ticketnew admin my_summary my_ticket_type component1 my_description

I GET ERROR

xmlrpclib.ProtocolError: <ProtocolError for admin:password@myserver.mydomain.com/trac_admin/projectname/login/xmlrpc: 500 Internal Server Error>

but I successfully can create ticket from command line like this

 traccmd.py ticketnew admin my_summary my_ticket_type component1 my_description

Any idea whats going wrong?

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Ryan J Ollos

Priority: highestnormal
Severity: blockernormal

comment:2 Changed 9 months ago by Ryan J Ollos

Resolution: worksforme
Status: newclosed

I can't reproduce, but feel free to reopen if you'd like to continue debugging.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Nic Ferrier.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.