Modify

Opened 2 years ago

Closed 2 years ago

Last modified 14 months ago

#10354 closed task (fixed)

Plugin needs a license

Reported by: rjollos Owned by: mestudd
Priority: normal Component: ExtendedVersionPlugin
Severity: normal Keywords:
Cc: dcernea Trac Release: 0.12

Description

The plugin currently has no license. Would you allow a 3-Clause BSD license to be added to the source code? This is the same license that the Trac project uses.

Attachments (0)

Change History (5)

comment:1 Changed 2 years ago by rjollos

  • Resolution set to fixed
  • Status changed from new to closed

(In [12194]) Fixes #10354:

  • Applied 3-Clause BSD license, with permission of original author Malcolm Studd.
  • [12034] was not correct in stating that the 0.11 and 0.12 branches were the same. [10525] on the 0.12 branch not only broke 0.11 compatibility, but a read-only db connection was being passed to a method that called the commit operation. Restored 0.11 compatibility to the trunk.
  • Removed the navigation_item option, in order to simplify the behavior following [10525]. It is no longer possible to specify which navigation item is highlighted when the path matches versions, however this option did not seem very useful anyway, since the primary use cases will be captured by the roadmap_navigation option. If roadmap_navigation is true, the Roadmap entry in the main navigation will link to the versions page, and the Roadmap navigation entry will be highlighted when the path matches versions. If roadmap_navigation is false, a Versions entry will be added to the main navigation and will link to the versions page, and the Versions navigation entry will be highlighted when the patch matches versions.

comment:2 Changed 2 years ago by rjollos

(In [12195]) Fixes #10354: Passing the db object to Version.select is deprecated, and not necessary even in Trac 0.11.

comment:3 Changed 2 years ago by rjollos

(In [12229]) Refs #10354: Resolved various issues while trying to get plugin working on Trac 0.11:

  • extendedversion.environment could not be enabled since the link was grayed out. It appears there may have been a conflict of the class extendedversion.environment.EnvironmentSetup with trac.env.EnvironmentSetup. Renamed extendedversion.environment.EnvironmentSetup to extendedversion.db.ExtendedVersionSetup.
  • Moved ITemplateProvider methods to the version module.
  • FIX: INavigationContributor in the version module needs to return an empty list. The versions tab is still not highlighted correctly when on a version page.

comment:4 Changed 2 years ago by rjollos

(In [12231]) Refs #10354:

  • Fixed error in request handling that prevented creating a new version.
  • Organized some code in roadmap.py.

comment:5 Changed 14 months ago by rjollos

In 13342:

Fixed regression from [12231]. Refs #10354, #11179.

VisibleVersion.match_request should not return True for the path /versions.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.