Modify

Opened 20 months ago

Closed 20 months ago

Last modified 19 months ago

#10841 closed defect (invalid)

Exact position of link Delete Ticket and Delete Changes.

Reported by: lborz@… Owned by: rjollos
Priority: normal Component: TicketDeletePlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description (last modified by rjollos)

Hi,


I'm an user of Trac. My Trac version is 0.12.5dev-r11463. Plugin installed are:

  • BlackMagicTicketTweaks 0.11r1
  • privatereports 0.3
  • TicketReminderPlugin 0.1.1
  • TracAccountManager 0.3.2
  • TracTicketChainedFields 0.1

I enabled the component adding in the trac.ini file at the end of section [components] the line: tracopt.ticket.deleter = enabled
To be sure that the modification is active, I gave the command: /etc/init.d/apache2 restart

Maybe I didn't understand very well where the links Delete Ticket and Delete Changes will appear. After reading your help page of plugin, I suppose that when I open the Admin page, that links will appear in the Administration left menu. That's doesn't happen. I'm looking in the wrong place or what?


Thank you in advance for your reply, Luca.

Attachments (2)

DeleteButton.png (15.7 KB) - added by anonymous 20 months ago.
TracoptTicketDeleterDocumentation.png (21.6 KB) - added by anonymous 20 months ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 20 months ago by rjollos

  • Resolution set to invalid
  • Status changed from new to closed

Hi, The tracopt.ticket.deleter is part of the Trac core and different from this plugin. The plugin here is obsolete for Trac >= 0.12.

The documentation for tracopt.ticket.deleter can be found on the WebAdmin panel, IIRC. There might be a TICKET_DELETE permission you need to grant. You might also want to try as a user with TICKET_ADMIN. I can't recall the details.

comment:2 Changed 20 months ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:3 Changed 20 months ago by lborz@…

I use the default admin user of Trac, that has the permission TICKET_ADMIN. From Trac help I see that the permission TICKET_DELETE is not available.

What I got when I open the Admin section of Trac is this menu:


Administration

  • General
  • Basic settings
  • Logging
  • Permissions
  • Plugins

Accounts

  • Configuration
  • Users

PrivateReports

  • PrivateReports

Ticket System

  • Chained Fields

Ticket system

  • Components
  • Milestones
  • Priorities
  • Resolutions
  • Severities
  • Ticket types
  • Versions

Version control

  • Repositories

I suppose that the link "Ticket delete" will be available in this menu, but there isn't. To be sure, is this menù that you mean when you wrote "WebAdmin panel, IIRC"?

Cheers, Luca.

comment:4 Changed 20 months ago by rjollos

  • Resolution set to invalid
  • Status changed from reopened to closed

I'm happy to help you work to resolve the issue, but it is not an issue with the plugin, so let's keep the ticket closed. I'll do some investigation and report back shortly.

comment:5 Changed 20 months ago by rjollos

  • Description modified (diff)

Changed 20 months ago by anonymous

comment:6 Changed 20 months ago by rjollos

Unless you have a typo in this ticket description, then the issue is most likely that you need to specifiy tracopt.ticket.deleter.* = enabled. You have claimed to specify tracopt.ticket.deleter = enabled, omitting the trailing .*.

Here is what you should see:

The ticket deleter component that Trac provides does not appear to have an admin panel for deleting tickets. I'm fairly sure the component in Trac was rewritten and has nothing to do with the TicketDeletePlugin.

Changed 20 months ago by anonymous

comment:7 Changed 20 months ago by rjollos

The following screen capture of the tracopt.ticket.deleter documentation from the Admin > Plugins panel may be helpful:


comment:8 Changed 20 months ago by anonymous

I suggest to you to modify the homepage of the plugin on Trac Hacks site. Especially this line:

Note: The functionality of this plugin has been incorporated into Trac 0.12 t:#3641. There is no need to follow the installation steps below if you are using Trac 0.12. Just edit your trac.ini:
[components]
tracopt.ticket.deleter = enabled

comment:9 Changed 20 months ago by lborz@…

Thank for the help any way.

comment:10 Changed 20 months ago by rjollos

I modified the TicketDeletePlugin page to try and be more clear. Please let me know if you think it is an improvement, or if you have any other suggestions for improving it.

comment:11 follow-up: Changed 19 months ago by lborz@…

Sorry to be silly, but I still see in the red square this line: tracopt.ticket.deleter = enabled. In the Installation paragraph it's correct.

comment:12 Changed 19 months ago by rjollos

What is wrong with that? It is instructing you how to enable the new component in Trac.

comment:13 in reply to: ↑ 11 Changed 19 months ago by rjollos

Replying to lborz@opera21.it:

Sorry to be silly, but I still see in the red square this line: tracopt.ticket.deleter = enabled. In the Installation paragraph it's correct.

It seems like we still have a disconnect here. The red square is telling you to not install TicketDeletePlugin for Trac 0.12 and later. Instead, enable tracopt.ticket.deleter = enabled to obtain equivalent functionality provided in Trac 0.12 and later. The installation section is telling you how to install TicketDeletePlugin for Trac < 0.12.

I've added some more clarifications:

Note: TicketDeletePlugin is deprecated for Trac 0.12 and later, and will no longer be supported except for critical fixes. Trac 0.12 (t:#3641) added a ticket deleter component, so there is no need to install TicketDeletePlugin if you are using Trac 0.12+. To enable functionality equivalent to TicketDeletePlugin in Trac 0.12 and later, just edit your trac.ini:

[components]
tracopt.ticket.deleter = enabled

The tracopt.ticket.deleter component was written by the Trac team and has essentially the same functionality as TicketDeletePlugin, but the implementation has no direct relation to TicketDeletePlugin. One major difference is that there is no WebAdmin component for the Trac ticket deleter as there was for TicketDeletePlugin.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.