Modify

Opened 7 years ago

Closed 6 years ago

#2922 closed defect (worksforme)

Parent module 'tracrpc' not loaded error

Reported by: anonymous Owned by: athomas
Priority: highest Component: XmlRpcPlugin
Severity: critical Keywords:
Cc: Trac Release: 0.11

Description

I'm new to python and trac so the answer to this may be obvious.

My env. is a standalone installation on winxp sp2, trac 0.11b2, tracd is started with BASIC_AUTH. My goal is to link with mylyn/eclipse.

To install the plugin I called: c:\python25\Scripts\easy_install D:\temp\tracxmlrpc\xmlrpcplugin\0.10

The error is triggered by settings in trac.ini. I always get the error with tracrpc.* enabled.

I've tried e.g. selecting RPC combinations in the webadmin interface. On Stderr/out tracd console I get: 20:09:54 Trac[env] INFO: Reloading environment due to configuration change 20:09:54 Trac[loader] DEBUG: Loading TracXMLRPC from c:\python25\lib\site-packag es\tracxmlrpc-0.1-py2.5.egg 20:09:54 Trac[loader] ERROR: Skipping "TracXMLRPC = tracrpc": (can't import "No module named Search") : :

As soon as I select XMLRPCWeb(this equates to "tracrpc.web_ui.xmlrpcweb = enabled" in trac.ini), trac disappears and instead in the browser I get: Traceback (most recent call last):

File "c:\Python25\lib\site-packages\trac\web\api.py", line 339, in send_error

'text/html')

File "c:\Python25\lib\site-packages\trac\web\chrome.py", line 672, in render_template

template = self.load_template(filename, method=method)

File "c:\Python25\lib\site-packages\trac\web\chrome.py", line 648, in load_template

self.templates = TemplateLoader(self.get_all_templates_dirs(),

File "c:\Python25\lib\site-packages\trac\web\chrome.py", line 402, in get_all_templates_dirs

dirs += provider.get_templates_dirs()

File "build\bdist.win32\egg\tracrpc\web_ui.py", line 76, in get_templates_dirs

from pkg_resources import resource_filename

SystemError: Parent module 'tracrpc' not loaded

My hunch is that I need xmlrpcplugin\0.11? All help appreciated. Mike

Attachments (0)

Change History (11)

comment:1 follow-up: Changed 7 years ago by Adrien

Hi I had the same problem. The pg came from this : c:\python25\Scripts\easy_install D:\temp\tracxmlrpc\xmlrpcplugin\0.10.

You should try xmlrpcplugin\trunk instead of xmlrpcplugin\0.10 Adrien

comment:2 Changed 7 years ago by anonymous

Tried the xmlrpcplugin\trunk by calling (for python novices like me) c:\python25\Scripts\easy_install D:\temp\tracxmlrpc\xmlrpcplugin\trunk and it worked!

I found the tips at http://unitstep.net/blog/2008/01/19/using-assemblas-trac-with-eclipse-mylyn-xml-rpc-access/ to be helpful (section 4 "The Fix")

comment:3 Changed 7 years ago by anonymous

Ooops, I forgot to say THANKS!

comment:4 in reply to: ↑ 1 Changed 7 years ago by anonymous

You should try xmlrpcplugin\trunk instead of xmlrpcplugin\0.10

I tried that alternative, but still the same error on Trac rc0.11.

comment:5 follow-up: Changed 7 years ago by athomas

#3232 is a duplicate of this ticket.

Have you tried moving the from pkg_resources import resource_filename to the top of the file? Does that fix it?

comment:6 in reply to: ↑ 5 Changed 7 years ago by iperezr@…

  • Priority changed from normal to highest
  • Severity changed from normal to critical

Replying to athomas:

#3232 is a duplicate of this ticket.

Have you tried moving the from pkg_resources import resource_filename to the top of the file? Does that fix it?

No, Don´t fix. The problem is persist.

comment:7 Changed 6 years ago by anonymous

I found a way around

build TracXMLRPC-0.1-py2.5.egg (xmlrpcplugin\1.0) build TracXMLRPC-1.0.0-py2.5.egg (xmlrpcplugin\trunk)

copy both into plugins

restart service

works

Mike

comment:8 Changed 6 years ago by fizze

Yes, I can confirm this works!

If you build both .eggs (one in 0.10 and one in trunk) they will be copied into the plugin folder anyway. So all that is needed is to restart trac - and voilà!

comment:9 Changed 6 years ago by anonymous

using the trunk works with 0.11

comment:10 Changed 6 years ago by anonymous

trunk works out of the box with Trac 0.11, Python 2.5, Apache 2.2.11/mod_python, Eclipse Ganymede (3.4.1) and Mylyn 3.0

comment:11 Changed 6 years ago by osimons

  • Resolution set to worksforme
  • Status changed from new to closed

Yup. Using trac 0.11 with xmlrpc plugin from trunk should not be a problem.

Closing.

Add Comment

Modify Ticket

Action
as closed The owner will remain athomas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.