Modify

Opened 6 years ago

Closed 6 years ago

#3232 closed defect (duplicate)

Problem with XMLRPC plugins on trac 0.11

Reported by: iperezr@… Owned by: athomas
Priority: highest Component: XmlRpcPlugin
Severity: critical Keywords:
Cc: Trac Release: 0.11

Description

So i have this problem on TRac 0.11 release when i active xmlrpc plugin. The code of trunk i compile and i use that .egg.

So i have this error:


Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/web/api.py", line 339, in send_error
    'text/html')
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/web/chrome.py", line 683, in render_template
    template = self.load_template(filename, method=method)
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/web/chrome.py", line 659, in load_template
    self.templates = TemplateLoader(self.get_all_templates_dirs(),
  File "/usr/lib/python2.5/site-packages/Trac-0.11-py2.5.egg/trac/web/chrome.py", line 406, in get_all_templates_dirs
    dirs += provider.get_templates_dirs()
  File "build/bdist.linux-i686/egg/tracrpc/web_ui.py", line 76, in get_templates_dirs
    from pkg_resources import resource_filename
SystemError: Parent module 'tracrpc' not loaded

Please help!!!

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by athomas

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2922.

The only thing I can suggest is you try moving the from pkg_resources import resource_filename to the top of the file. Does that work?

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from athomas. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.