Modify

Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#2958 closed defect (fixed)

[Patch] Error with themeengine.admin

Reported by: lit-uriy@… Owned by: coderanger
Priority: high Component: ThemeEnginePlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

If I enable components themeengine.api themeengine.web_ui WebAdmin or in the ini-file, everything works well. But if I enable component themeengine.admin then pressing the button "Admin" on the site leads to error.

Attachments (1)

patch.diff (688 bytes) - added by payala 5 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by coderanger

Known issue. I haven't finished porting the GUI component. For now you just have to set the theme in trac.ini the old-fashioned way.

Changed 5 years ago by payala

comment:2 Changed 5 years ago by payala

The submitted patch, in addition to the fix proposed in ticket:4344 worked fine for me.

comment:3 Changed 5 years ago by rjollos

  • Summary changed from error with themeengine.admin to [Patch] Error with themeengine.admin

comment:4 Changed 4 years ago by rjollos

Any objection if I go ahead and commit this patch? It seems to work well, and will at least fix some broken behavior until you get to finish porting.

comment:5 Changed 4 years ago by coderanger

  • Resolution set to fixed
  • Status changed from new to closed

This was fixed 6 months ago :-P

comment:6 Changed 4 years ago by rjollos

Oh, thanks! Last time I used it was about 6 months ago and I'm just now looking to use it again and was remembering that it was required. Now that I look at the changelog, looks like you did quite a bit of work fixing it up in Feb.

Add Comment

Modify Ticket

Action
as closed The owner will remain coderanger.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.