Modify

Opened 6 years ago

Closed 5 years ago

#3176 closed defect (fixed)

Error loading LuntbuildTracIntegration

Reported by: dpankros@… Owned by: diroussel
Priority: normal Component: LuntbuildTracIntegration
Severity: blocker Keywords:
Cc: Trac Release: 0.10

Description

Setup component with:
easy_install http://trac-hacks.org/svn/luntbuildtracintegration/0.10/
(everything OK)
To envrinment trac.ini, I added: (I've also tried it without this entry)
[components]
luntbuildtracintegration.* = enabled

I added the requisite luntbuild info in trac.ini.

Then I restarted apache2. When trying to access trac I get the following error:

2008-06-11 14:09:34,469 Trac[loader] DEBUG: Loading egg plugin LuntbuildTracIntegration from /usr/lib/python2.5/site-packages/LuntbuildTracIntegration-1.1-py2.5.egg
2008-06-11 14:09:34,474 Trac[loader] ERROR: Failed to load plugin LuntbuildTracIntegration from /usr/lib/python2.5/site-packages/LuntbuildTracIntegration-1.1-py2.5.egg
Traceback (most recent call last):

File "/var/lib/python-support/python2.5/trac/loader.py", line 101, in load_components

entry_point.load()

File "/usr/lib/python2.5/site-packages/setuptools-0.6c8-py2.5.egg/pkg_resources.py", line 1912, in load

entry = import(self.module_name, globals(),globals(), __name__?)

ImportError: No module named LuntbuildTracIntegration.Plugin

I don't see any output from the plugin.

Trac: 0.10.4
Python: 2.5

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by www.3DH.de

Hi,

I had the same error and solved it by:

  1. after running easy_install rename the *.egg into *.zip and create a dir with the *.egg name: LuntbuildTracIntegration-1.1-py2.5.egg
  2. change into the dir and unpack the zip (the renamed .egg file)
  3. edit EGG-INFO\entry-points.txt
  4. remove the "." befor "Plugin" so that your file should look like this:

EGG-INFO\entry-points.txt:

[trac.plugins]
LuntbuildTracIntegration = LuntbuildTracIntegration.LuntbuildTracIntegrationPlugin
  1. enable the plugin in trac.ini with luntbuildtracintegration.* = enabled
  2. restart trac

comment:2 Changed 6 years ago by diroussel

I've applied a fix for this in changeset:4533, but as I don't run luntbuild any more I haven't tested it. Let me know if it works or not.

comment:3 Changed 6 years ago by diroussel

closed ticket:2292 as a duplicate of this

comment:4 Changed 5 years ago by diroussel

  • Status changed from new to assigned

comment:5 Changed 5 years ago by diroussel

  • Resolution set to fixed
  • Status changed from assigned to closed

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from diroussel. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.