Modify

Opened 6 years ago

Closed 5 years ago

Last modified 3 years ago

#3851 closed defect (fixed)

TAGS_VIEW not showing page tags along for anonymous

Reported by: izzy Owned by: otaku42
Priority: normal Component: TagsPlugin
Severity: major Keywords: wiki page
Cc: Trac Release: 0.11

Description

We have granted TAGS_VIEW to anonymous. So without logging in, the "Tags" menu item in main_nav shows up, and the tags are also listed there. However, when viewing some Wiki article, its tags are not displayed.

Attachments (1)

tractags-fix-tags-anonymous.patch (560 bytes) - added by quad 6 years ago.
Fixes the bug where tags don't show up when not authenticated.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 years ago by alerocha

I fixed it in my environment.

The point is that the list of tags must appear before the buttons (div with class called buttons wich show the actions) but this div is not in the string when the user has no permission to modify or delete wiki pages.

So the code that puts the cloud into string must be changed

TracTags => wiki.py
Line 99: return stream | Transformer('div[@class="buttons"]').before(insert)

If another div will be used instead class=buttons the bug is fixed.

In my case I changed the css too

comment:2 Changed 6 years ago by quad

  • Severity changed from normal to major

Experiencing this behavior also. Sounds like an important defect to me as it completely prevents visitors from viewing tags (default configuration, anonymous users). Please change back if you don't agree.

I am myself not too sure of what must be changed exactly, but until it's fixed I'll give it a try at modifying my local working copy of trunk.

Changed 6 years ago by quad

Fixes the bug where tags don't show up when not authenticated.

comment:3 Changed 6 years ago by quad

Just attached a patch that make the tags reappear. Basically, it adds the tags section relative to the main page section, rather that to the div containing the buttons.

comment:4 Changed 5 years ago by otaku42

  • Owner changed from athomas to otaku42

I cannot reproduce the described issue with r7373 and Trac 0.11.6. Can someone please confirm that this issue still exists for them, and that the patch attached to this ticket is required for them to fix it?

comment:5 Changed 5 years ago by izzy

As the reporter, this should probably be my task - but I have no longer access to those environments as I "left that company" and switched to a new project, sorry.

comment:6 Changed 5 years ago by otaku42

  • Status changed from new to assigned

Now I was able to reproduce the reported issue, comment:3 pointed me in the right direction :)

The issue occurs only for users that have TAGS_VIEW but not WIKI_MODIFY. There are no buttons without WIKI_MODIFY, thus the stream filter fails. The patch submitted by quad works as intended and fixes the issue, I'll commit it to the repos now.

comment:7 Changed 5 years ago by otaku42

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7384]) Fix bug where wiki page tags were not displayed for users that have
TAGS_VIEW permission but not WIKI_MODIFY. Thanks to quad for the patch.
Fixes #3851.

comment:8 Changed 3 years ago by hasienda

  • Keywords wiki page added

#8467 has been closed as a duplicate of this ticket.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from otaku42. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.