Modify

Opened 6 years ago

Closed 4 years ago

#4359 closed defect (fixed)

Votes plugin fails to install on Linux / MySQL

Reported by: belgarat@… Owned by: rjollos
Priority: normal Component: VotePlugin
Severity: critical Keywords:
Cc: Trac Release: 0.11

Description

MySQL on Linux is case-sensitive. There's a uppercase reference to 'votes' table in environment_needs_upgrade, which fails always.

Please change

SELECT COUNT(*) FROM VOTES

to

SELECT COUNT(*) FROM votes

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by anonymous

how could this be unresolved after eight months?

comment:2 Changed 4 years ago by rjollos

  • Owner changed from athomas to rjollos

Reassigning ticket to new maintainer.

comment:3 Changed 4 years ago by rjollos

  • Resolution set to fixed
  • Status changed from new to closed

Current 0.11 version has cursor.execute("select count(*) FROM votes"). Looks like this has been fixed already, though I don't run MySQL so I can't confirm.

I'd appreciate if you are able to test the latest 0.11 and confirm that the issue is fixed.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.