Modify

Opened 5 years ago

Closed 5 years ago

#5636 closed defect (fixed)

Hudson plugin, python 2.4 and trac-0.11.6stable doesn't start

Reported by: brett.dellegrazie@… Owned by: roadrunner
Priority: normal Component: HudsonTracPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Hi,

After a clean install of Trac (served via mod_wsgi) and installation of the Hudson plugin, Trac no longer starts.

versions:
OS: RHEL5.3
Trac: 0.11.6stable r8448
mod_wsgi: 2.1-2.el5
python: 2.4.3-24.el5_3.6
HudsonTracPlugin: r6343 (from local checkout of source)

The stack trace I get is:

Traceback (most recent call last):

File "/usr/lib/python2.4/site-packages/Trac-0.11.6stable_r0-py2.4.egg/trac/web/api.py", line 377, in send_error

'text/html')

File "/usr/lib/python2.4/site-packages/Trac-0.11.6stable_r0-py2.4.egg/trac/web/chrome.py", line 725, in render_template

req.chrome[type_].append(

File "/usr/lib/python2.4/site-packages/Trac-0.11.6stable_r0-py2.4.egg/trac/web/api.py", line 195, in getattr

value = self.callbacks[name](self)

File "/usr/lib/python2.4/site-packages/Trac-0.11.6stable_r0-py2.4.egg/trac/util/compat.py", line 135, in newfunc

return func_(*(args + fargs), dict(kwargs, fkwargs))

File "/usr/lib/python2.4/site-packages/Trac-0.11.6stable_r0-py2.4.egg/trac/web/chrome.py", line 488, in prepare_request

for contributor in self.navigation_contributors:

File "/usr/lib/python2.4/site-packages/Trac-0.11.6stable_r0-py2.4.egg/trac/core.py", line 70, in extensions

return filter(None, [component.compmgr[cls] for cls in extensions])

File "/usr/lib/python2.4/site-packages/Trac-0.11.6stable_r0-py2.4.egg/trac/core.py", line 207, in getitem

component = cls(self)

File "/usr/lib/python2.4/site-packages/Trac-0.11.6stable_r0-py2.4.egg/trac/core.py", line 111, in maybe_init

init(self)

File "build/bdist.linux-x86_64/egg/HudsonTrac/HudsonTracPlugin.py", line 51, in init

AttributeError: 'tuple' object has no attribute 'scheme'

hope you can help.

Thanks,

Brett

Attachments (2)

trac.log (11.1 KB) - added by brett.dellegrazie@… 5 years ago.
trac.log sample from startup in debug mode
trac.2.log (13.4 KB) - added by brett.dellegrazie@… 5 years ago.
trac.log sample with url log

Download all attachments as: .zip

Change History (8)

comment:1 Changed 5 years ago by roadrunner

It looks like you may have misconfigured the feed_url option - make
sure it is an absolute url, i.e. including a scheme, e.g.
'http://localhost/hudson/rssAll' and not just '/hudson/rssAll'.

comment:2 follow-up: Changed 5 years ago by brett.dellegrazie@…

Hi,

I haven't misconfigured the feed_url option (that I can see) my trac.ini is below. I have also attached the trac.log in DEBUG mode from startup.

[hudson]
feed_url=http://buildsystem.iris2.local/rssAll
username=
password=
display_subprojects=false
main_page=http://buildsystem.iris2.local/
display_in_new_tab=true
alternate_success_icon=true
display_build_descriptions=true

Changed 5 years ago by brett.dellegrazie@…

trac.log sample from startup in debug mode

comment:3 in reply to: ↑ 2 Changed 5 years ago by roadrunner

Replying to brett.dellegrazie@intact-is.com:

I haven't misconfigured the feed_url option (that I can see) my
trac.ini is below. I have also attached the trac.log in DEBUG mode
from startup.

[hudson]
feed_url=http://buildsystem.iris2.local/rssAll

Thanks. Hmm, something's odd - for some reason the feed-url isn't
being parsed properly. Can you add the following line to
HudsonTracPlugin.py, just after line 50 (i.e. after the url is parsed
but before base_url gets set):

  self.env.log.info("Using feed at '%s' (%s)" % (self.feed_url, url_parts))

and then show me the output in the log?

TIA.

comment:4 follow-up: Changed 5 years ago by brett.dellegrazie@…

Hi,

I have done as you requested, the new trac.log is attached. Thanks for your help with this.

Changed 5 years ago by brett.dellegrazie@…

trac.log sample with url log

comment:5 in reply to: ↑ 4 Changed 5 years ago by roadrunner

  • Status changed from new to assigned

Replying to brett.dellegrazie@intact-is.com:

I have done as you requested, the new trac.log is attached. Thanks
for your help with this.

Thanks. Ok, looks like the issue is that you're using python 2.4 but
the plugin is using something that was added in 2.5. Checking in a fix
now.

comment:6 Changed 5 years ago by roadrunner

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [6371]) Fix #5636. urlparse added attributes to the result in python 2.5, so using
those breaks installations using 2.4. Therefore changed to use indexes instead.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from roadrunner. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.