Modify

Opened 4 years ago

Closed 4 years ago

#6814 closed defect (fixed)

EmailVerification does not send emails, regression between r7486 and r7731

Reported by: peter@… Owned by: mgood
Priority: normal Component: AccountManagerPlugin
Severity: major Keywords: email notification
Cc: Trac Release: 0.11

Description

The green span box is shown when Trac should send or resend the email, but no email is generated.
The log shows "Trac[api] INFO: Email verification requested user: username" but nothing else happens. Other emails are sent out from Trac without problems.

I looked into this. Only AccountManager.user_email_verification_requested gets called and it creates the log message, but AccountChangeListener.user_email_verification_requested is not getting called, which is what would call EmailVerificationNotification.notify. I don't know how to bridge the gap.

In r7486 EmailVerificationModule.post_process_request calls self._send_email, which calls EmailVerificationNotification.notify directly.

Until r7731 it was changed to reuse another instance of AccountManager and it seems there's an issue.

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by Olaf Meeuwissen <olaf.meeuwissen@…>

#6817 and #7013 are probably related.

comment:2 Changed 4 years ago by anonymous

There is a documented workaround.

comment:3 Changed 4 years ago by peter@…

  • Resolution set to fixed
  • Status changed from new to closed

Yep, it seems that these three tickets are all the same issue.

I'm not seeing this problem anymore however. Maybe because I have now upgraded to Trac 0.12b1.

Even if I explicitly disable the setting in the suggested workaround:

acct_mgr.notification.accountchangelistener = disabled

I still get emails sent out for email verification as well as password reminders. So this is fixed for me anyway.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from mgood. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.