Modify

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#7013 closed defect (duplicate)

r7731 breaks password reset notification

Reported by: anonymous Owned by: mgood
Priority: normal Component: AccountManagerPlugin
Severity: major Keywords: regression
Cc: rohieb@… Trac Release: 0.11

Description

After updating from r7730 to r7731, I was no longer able to receive password reset notifications via SMTP to my email address. r7730 works fine, I just tested it :)

Here is what I did:

  • enabled Trac logging to file
  • updated to accountmanager-r7730
  • easy_install
  • reset password using the web interface (Login -> "Forgot your password?")
  • found a password reset notification in my mailbox, and the Trac logfile said:
    2010-04-21 19:04:55,869 Trac[notification] INFO: Sending SMTP notification to localhost:25 to [u'example@example.org']
    2010-04-21 19:04:55,881 Trac[notification] WARNING: sendmail from: "Trac" <trac@example.org> to [u'example@example.org']
    2010-04-21 19:04:56,149 Trac[api] INFO: Updated password for user: rohieb
    

(of course, example.org was in fact my domain name ;-))

  • updated to accountmanager-r7731
  • easy_install
  • reset password using the web interface (Login -> "Forgot your password?")
  • found no mail in my mailbox, but also no lines from Trac[notification] in the logfile, although the same line from Trac[api] existed. Obviously, the handlers in Trac[notification] are not called, but my password is reset!

I am not a very good Python/Trac hacker, but I may be able to create a patch if I have the time.

Attachments (0)

Change History (6)

comment:1 Changed 4 years ago by anonymous

After updating from r7730 to r7731, I was no longer able to receive password reset notifications via SMTP to my email address. This is not the case with r7730.

Here is what I did:

  • enabled Trac logging to file
  • updated to accountmanager-r7730
  • easy_install
  • reset password using the web interface (Login -> "Forgot your password?")
  • found a password reset notification in my mailbox, and the Trac logfile said:
    2010-04-21 19:04:55,869 Trac[notification] INFO: Sending SMTP notification to localhost:25 to [u'example@example.org']
    2010-04-21 19:04:55,881 Trac[notification] WARNING: sendmail from: "Trac" <trac@example.org> to [u'example@example.org']
    2010-04-21 19:04:56,149 Trac[api] INFO: Updated password for user: rohieb
    

(of course, example.org was in fact my domain name ;-))

  • updated to accountmanager-r7731
  • easy_install
  • reset password using the web interface (Login -> "Forgot your password?")
  • found no mail in my mailbox, but also no lines from Trac[notification] in the logfile, although the same line from Trac[api] existed. Obviously, the handlers in Trac[notification] are not called, but my password is reset!

I am not a very good Python/Trac hacker, but I may be able to create a patch if I have the time.

comment:2 Changed 4 years ago by rohieb@…

  • Cc rohieb@… added

(add myself to cc)

comment:3 Changed 4 years ago by Olaf Meeuwissen <olaf.meeuwissen@…>

Looks like #6814 and #6817 are related.

comment:4 follow-up: Changed 4 years ago by Olaf Meeuwissen <olaf.meeuwissen@…>

  • Severity changed from normal to major

Setting

acct_mgr.notification.AccountChangeListener = enabled

made SMTP notification work again for me.

For better or for worse (worse if you ask me), r7731 moves the password reset and email verification SMTP notifications to the AccountChangeListener API. If that component is not enabled, the SMTP notifications are never generated. Passwords are reset and permissions temporarily revoked nevertheless.

comment:5 Changed 4 years ago by peter@…

  • Resolution set to duplicate
  • Status changed from new to closed

Yes, I'd say this is the same issue as #6814

comment:6 in reply to: ↑ 4 Changed 3 years ago by jack+trac@…

Replying to Olaf Meeuwissen <olaf.meeuwissen@avasys.jp>:

Setting

acct_mgr.notification.AccountChangeListener = enabled

made SMTP notification work again for me.

Not for me. It took me hours to figure out. What eventually fixed it was this:

acct_mgr.notification.accountchangelistener = enabled

That is, it's case-sensitive.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from mgood. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.