Modify

Opened 4 years ago

Closed 3 years ago

#8043 closed defect (worksforme)

trac-tags broken with env needs upgrade error

Reported by: anonymous Owned by: rjollos
Priority: high Component: TagsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description (last modified by rjollos)

On a 'clean' install of trac (eg: webfaction one-click installer 0.12, as well as from trac trunk), I tried to add the tractags plugin (both 0.6 and trunk, same issue). After upgrading the environment, it kept insisting I upgrade, and when I tried that, it gave an error (tag table already exists). After poking around, I found this is what triggers it:

WARNING: Component <tractags.model.TagModelProvider object at 0x9afe44c> requires environment upgrade

I added this to [components], which seems to work-around it for now:

tractags.model.tagmodelprovider = disabled

Without this, it's not possible to run this plugin.

be well, --craig

Attachments (0)

Change History (9)

comment:1 Changed 4 years ago by shentonfreude

I've been fighting with this the past couple days as well, with a buildout-installed 0.12 and a handful of other plugins, on python-2.7. (I found that the trunk/ version did install, but didn't play with the keywordsuggest autocomplete patch so I had to use tractags-0.6.

Your work-around really helped me out, thanks.

But I still don't understand the problem. I have tractags-0.6 running successfully on another Trac, but it's 0.11.

comment:2 Changed 4 years ago by guardian

Used the workaround given by craig on a Trac 0.12 installation with 0.6 version of the TagsPlugin.

What's the consequence of setting tractags.model.tagmodelprovider = disabled exactly?

comment:3 Changed 4 years ago by rjollos

  • Description modified (diff)

comment:4 Changed 4 years ago by guardian

  • Owner changed from athomas to otaku42

took the liberty to reassign ticket

comment:5 Changed 4 years ago by matthew

We also found this workaround successful on Trac 0.12 with plugin v0.6, but would also like to know what consequences, if any, we're suffering. Before we upgraded from 0.11, we had no problems.

comment:6 Changed 4 years ago by brian@…

+1

(just commenting to get notified if someone fixed this :) )

comment:7 Changed 4 years ago by anonymous

Issue on Trac 0.12.1 with plugin v0.6 - plugin works fine for wiki pages but tags from tickets do not register.

YMMV but when I set changed ticket_fields = keywords, component to just ticket_fields = keywords the tickets started showing up...

comment:8 Changed 3 years ago by rjollos

  • Owner changed from otaku42 to rjollos
  • Status changed from new to assigned

This might be resolved by [10382] (refs #5345). Can someone install the latest version of the trunk, test and report back? Thanks.

comment:9 Changed 3 years ago by rjollos

  • Resolution set to worksforme
  • Status changed from assigned to closed

Closing since there was no response. Please reopen if you continue to experience the issue with the latest version of the trunk.

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.