Modify

Opened 3 years ago

Closed 14 months ago

#8915 closed defect (duplicate)

AttributeError: hdf

Reported by: admin Owned by: StefanSimroth
Priority: high Component: GoogleCalendarPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.12

Description

How to Reproduce

While doing a GET operation on /calendar, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{}

User agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17

System Information

Trac 0.13dev-r10696
Genshi 0.6
MySQL server: "5.1.51", client: "5.1.51", thread-safe: 1
MySQLdb 1.2.3
Python 2.6.1 (r261:67515, Jun 24 2010, 21:47:49)
[GCC 4.2.1 (Apple Inc. build 5646)]
pytz 2010o
setuptools 0.6c12
Subversion 1.6.5 (r38866)
jQuery 1.5.1

Enabled Plugins

GoogleCalendar 0.1.2
SvnAuthzAdminPlugin 0.1.2.-Moved.to.Trac.0.11-
TracAccountManager 0.3dev
TracTocMacro 11.0.0.3

Python Traceback

Traceback (most recent call last):
  File "/Library/Python/2.6/site-packages/Trac-0.13dev_r10696-py2.6.egg/trac/web/main.py", line 473, in _dispatch_request
    dispatcher.dispatch(req)
  File "/Library/Python/2.6/site-packages/Trac-0.13dev_r10696-py2.6.egg/trac/web/main.py", line 193, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.macosx-10.6-universal/egg/googlecalendar/googlecalendar.py", line 30, in process_request
    req.hdf['title'] = 'Calendar'
  File "/Library/Python/2.6/site-packages/Trac-0.13dev_r10696-py2.6.egg/trac/web/api.py", line 306, in __getattr__
    raise AttributeError(name)
AttributeError: hdf

Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by rjollos

  • Component changed from SELECT A HACK to GoogleCalendarPlugin
  • Owner set to StefanSimroth

Yet another incorrectly filed ticket.

comment:2 Changed 2 years ago by StefanSimroth

  • Severity changed from normal to blocker
  • Trac Release changed from 0.11 to 0.12

see also #9686 -> incompatible with 0.12 or higher

comment:3 Changed 2 years ago by StefanSimroth

  • Priority changed from normal to high

comment:4 Changed 14 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8128. On 0.12, you can install ClearSilver. However, for Trac >= 1.0, all ClearSilver support has been dropped.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from StefanSimroth. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.