Modify

Opened 2 years ago

Closed 11 months ago

#9686 closed defect (duplicate)

Incompatibility with 0.12 or higher

Reported by: fowie Owned by: StefanSimroth
Priority: high Component: GoogleCalendarPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.12

Description

0.12 no longer contains the clearsilver compatability code, so enabling the GoogleCalendar plugin on a 0.12 system now gives

AssertionError: HDF dataset not available. Check your clearsilver installation

Any chance of this being fixed?

Attachments (0)

Change History (6)

comment:1 in reply to: ↑ description ; follow-up: Changed 2 years ago by StefanSimroth

  • Summary changed from Incompatability with 0.12? to Incompatibility with 0.12
  • Trac Release changed from 0.11 to 0.12

Replying to fowie:

Any chance of this being fixed?

Not by me, I'm sorry to say. But anyone who wants to submit a patch is very welcome. All the plugin does is add an iframe with the calendar url.

comment:2 Changed 2 years ago by StefanSimroth

To achieve compatibility, it would basically mean to remove the clearsilver dependency as stated in #8128

comment:3 in reply to: ↑ 1 Changed 2 years ago by rjollos

Replying to StefanSimroth:

All the plugin does is add an iframe with the calendar url.

If that is the case, you might want to take a look at TracTabPlugin for an alternative.

comment:4 Changed 2 years ago by StefanSimroth

  • Summary changed from Incompatibility with 0.12 to Incompatibility with 0.12 or higher

see #8915 for exception on 0.13

comment:5 Changed 2 years ago by StefanSimroth

  • Priority changed from normal to high
  • Severity changed from normal to blocker

comment:6 Changed 11 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8128. On 0.12, you can install ClearSilver. However, for Trac >= 1.0, all ClearSilver support has been dropped.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from StefanSimroth. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.