Modify

Opened 2 years ago

Closed 21 months ago

#9634 closed defect (duplicate)

Error on database upgrade

Reported by: yamilchamut@… Owned by: coling
Priority: highest Component: ClientsPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.12

Description

I was getting this error after running trac-admin /path/to/trac/project upgrade:

root@trac:/home/yamil# trac-admin /path/to/trac/projectt upgrade
ClientsPlugin needs an upgrade
 * Upgrading db
Creating client table
Updating clients table (v3)
Updating clients table (v4)
Updating clients table (v5)
Updating clients table (v6)
 * Upgrading reports
UnboundLocalError: local variable 'version' referenced before assignment

As I stated on tickets #7450 and #8450, adding "global version" between lines 21 and 23 on reportmanager.py solves it.

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by anonymous

I'm sorry, that didn't solve it =(

comment:2 Changed 21 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7450. See that ticket for solution.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from coling. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.