Modify

Opened 2 years ago

Closed 4 weeks ago

#9988 closed defect (invalid)

this plugin is not working

Reported by: sandeep Owned by: framay
Priority: highest Component: BudgetingPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.12

Description

i have upgraded my trac from 0.11 to 0.12 for budgeting plugins but after installing tickets don't open they start showing error.

Attachments (1)

snipet of error.PNG (72.5 KB) - added by Sandeep Singh 2 years ago.

Download all attachments as: .zip

Change History (15)

Changed 2 years ago by Sandeep Singh

comment:1 in reply to: ↑ description ; follow-up: Changed 2 years ago by framay

Replying to sandeep:

i have upgraded my trac from 0.11 to 0.12 for budgeting plugins but after installing tickets don't open they start showing error.

What's the error? Is there any error message?

comment:2 in reply to: ↑ 1 ; follow-up: Changed 2 years ago by anonymous

Replying to framay:

Replying to sandeep:

i have upgraded my trac from 0.11 to 0.12 for budgeting plugins but after installing tickets don't open they start showing error.

What's the error? Is there any error message?

i have attached the error messages.

comment:3 in reply to: ↑ 2 Changed 2 years ago by framay

Replying to anonymous:

i have attached the error messages.

Well, the attached image is not displayed correctly in Trac-Hacks. I guess it is because you used spaces in the file name. Can you please upload it again without spaces and special characters.

Alternatively you can also paste the error message in the comments field.

comment:4 Changed 2 years ago by anonymous

Traceback (most recent call last):
  File "C:\Python26\lib\site-packages\trac\web\api.py", line 441, in send_error
    data, 'text/html')
  File "C:\Python26\lib\site-packages\trac\web\chrome.py", line 870, in render_template
    encoding='utf-8')
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\core.py", line 183, in render
    return encode(generator, method=method, encoding=encoding, out=out)
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\output.py", line 58, in encode
    for chunk in iterator:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\output.py", line 339, in __call__
    for kind, data, pos in stream:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\output.py", line 826, in __call__
    for kind, data, pos in stream:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\output.py", line 670, in __call__
    for kind, data, pos in stream:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\output.py", line 771, in __call__
    for kind, data, pos in chain(stream, [(None, None, None)]):
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\output.py", line 586, in __call__
    for ev in stream:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\core.py", line 288, in _ensure
    for event in stream:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\core.py", line 288, in _ensure
    for event in stream:
  File "C:\Python26\lib\site-packages\trac\web\chrome.py", line 973, in _generate
    for kind, data, pos in stream:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\core.py", line 288, in _ensure
    for event in stream:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\base.py", line 605, in _include
    for event in stream:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\markup.py", line 362, in _match
    content = list(content)
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\base.py", line 605, in _include
    for event in stream:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\markup.py", line 327, in _match
    for event in stream:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\markup.py", line 316, in _strip
    event = next()
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\base.py", line 545, in _flatten
    for kind, data, pos in stream:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\core.py", line 288, in _ensure
    for event in stream:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\path.py", line 588, in _generate
    subevent = next()
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\base.py", line 605, in _include
    for event in stream:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\markup.py", line 316, in _strip
    event = next()
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\base.py", line 545, in _flatten
    for kind, data, pos in stream:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\core.py", line 288, in _ensure
    for event in stream:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\path.py", line 588, in _generate
    subevent = next()
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\base.py", line 605, in _include
    for event in stream:
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\markup.py", line 316, in _strip
    event = next()
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\base.py", line 555, in _flatten
    for event in self._flatten(value, ctxt, **vars)
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\base.py", line 565, in _flatten
    result = _eval_expr(data, ctxt, vars)
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\base.py", line 277, in _eval_expr
    retval = expr.evaluate(ctxt)
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\eval.py", line 178, in evaluate
    return eval(self.code, _globals, {'__data__': data})
  File "C:\Python26\lib\site-packages\trac\templates\error.html", line 101, in <Expression u'project.admin_href.newticket()'>
    <form class="newticket" method="get" action="${project.admin_href.newticket()}#">
  File "C:\Python26\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\eval.py", line 277, in _die
    raise UndefinedError(self._name, self._owner)
UndefinedError: None has no member named "newticket"

comment:5 follow-up: Changed 2 years ago by anonymous

this is the error i am getting after installing budgeting plugins.

comment:6 follow-up: Changed 2 years ago by anonymous

  • Priority changed from high to highest
  • Severity changed from major to blocker

comment:7 in reply to: ↑ 6 Changed 2 years ago by anonymous

Replying to anonymous:
please reply soon as i am stuck with this plugin.

comment:8 in reply to: ↑ 5 ; follow-up: Changed 2 years ago by framay

Replying to anonymous:

this is the error i am getting after installing budgeting plugins.

Are you sure BudgetingPlugin causes the problem? In the pasted stacktrace there is nothing about budgeting. Might there another plugin or some special installation issue cuase the problem?

comment:9 in reply to: ↑ 8 ; follow-up: Changed 2 years ago by anonymous

Replying to framay:

Replying to anonymous:

this is the error i am getting after installing budgeting plugins.

Are you sure BudgetingPlugin causes the problem? In the pasted stacktrace there is nothing about budgeting. Might there another plugin or some special installation issue cuase the problem?

yes i am 100% sure about this because all my plugins are working perfectly.this is the error after installing the BudgetingPlugin.when i delete this plugin it start working normally.

comment:10 in reply to: ↑ 9 Changed 2 years ago by framay

Replying to anonymous:

yes i am 100% sure about this because all my plugins are working perfectly.this is the error after installing the BudgetingPlugin.when i delete this plugin it start working normally.

As the stacktrace shows no hint at which point the error might occur, I am a bit lost.

What exact versions of Trac and Budgeting are you using? Which database with which version do you use? Does the error only occur at new tickets or also at existing tickets? To avoid unknown and unexpected side-effects it would be good, if all other plugins would be disabled. Maybe setting log level to DEBUG and looking into log for something suspicious could also help.

comment:11 Changed 2 years ago by anonymous

IndentationError: ('unexpected indent', ('c:\\projects\\trac\\informatics\\plugins\\budgeting_plugin-0.6.0-py2.6.egg\\ticketbudgeting\\ticketbudgeting.py', 72, 4, '\t\t\t\texcept:\n'))
2012-05-02 12:05:09,700 Trac[loader] ERROR: Skipping "ticketbudgeting = ticketbudgeting": 
Traceback (most recent call last):
  File "C:\Python26\lib\site-packages\trac\loader.py", line 68, in _load_eggs
    entry.load(require=True)
  File "C:\Python26\lib\site-packages\pkg_resources.py", line 1954, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "build\bdist.win32\egg\ticketbudgeting\__init__.py", line 1, in <module>
  File "c:\projects\trac\informatics\plugins\budgeting_plugin-0.6.0-py2.6.egg\ticketbudgeting\ticketbudgeting.py", line 72
     except:
    ^
IndentationError: ('unexpected indent', ('c:\\projects\\trac\\informatics\\plugins\\budgeting_plugin-0.6.0-py2.6.egg\\ticketbudgeting\\ticketbudgeting.py', 72, 4, '\t\t\t\texcept:\n'))

comment:12 Changed 2 years ago by anonymous

this is the error picked from error log file.
It happens with both new ticket as well as the existing ticket.
I am using Trac 0.12.3 and the Budgeting_Plugin-0.6.0-py2.6.

comment:13 Changed 4 weeks ago by rjollos

Jun described the cause of the comment:4 error in comment:3:ticket:9193.

Based on the date comment:11 was reported and the line numbers in the traceback you must have been running r11191. Why are there tabs shown in the traceback? The source contains whitespace with the exception of two tabs on lines with comments.

Anyway, I suspect the issue can't be reproduced on the latest version of the trunk and the ticket can be closed.

comment:14 Changed 4 weeks ago by framay

  • Resolution set to invalid
  • Status changed from new to closed

Thank you Ryan for your detailed answer - I am closing this ticket.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.