Modify

Opened 5 years ago

Closed 4 years ago

Last modified 22 months ago

#10607 closed defect (fixed)

installing ChangeLogMacro from trunk forces Trac deployment to update

Reported by: anonymous Owned by: Ryan J Ollos
Priority: normal Component: ChangeLogMacro
Severity: normal Keywords: setuptools
Cc: Steffen Hoffmann Trac Release: 0.12

Description

I was running Trac 0.12.2; I downloaded the zip file of ChangeLogMacro, ran python ./trunk/setup.py install to install the trunk version. While this completed successfully, it forced my entire Trac deployment to upgrade. (each project reported an error, and required trac-admin /proj upgrade to be run) This was unexpected and could cause problems for others.

Attachments (0)

Change History (9)

comment:1 Changed 5 years ago by Ryan J Ollos

Keywords: needinfo added
Status: newassigned
Trac Release: 0.12

Is the error text Environment needs upgrade? I don't see how ChangeLogMacro could be forcing an upgrade since it doesn't implement IEnvironmentUpgradeParticipant.

comment:2 Changed 5 years ago by anonymous

Unfortunately, I didn't record the error, and I can't reproduce it. Since it was on a production instance, I went ahead with the upgrade.

comment:3 Changed 5 years ago by Ryan J Ollos

Okay, thanks for the info. I will try to reproduce the error and follow-up here in a bit.

comment:4 Changed 4 years ago by Ryan J Ollos

Cc: Steffen Hoffmann added; anonymous removed
Keywords: setuptools added; needinfo removed

I think I see what the issue is now. This is yet another reason to avoid install_requires=['Trac >= X.Y'] in setup.py.

comment:5 Changed 4 years ago by Ryan J Ollos

Resolution: fixed
Status: assignedclosed

In 13267:

Fixes #10607: Don't use install_requires to enforce a Trac version constraint, as it can inadvertently upgrade a user's installation.

comment:6 in reply to:  4 Changed 4 years ago by Steffen Hoffmann

Replying to rjollos:

I think I see what the issue is now. This is yet another reason to avoid install_requires=['Trac >= X.Y'] in setup.py.

Good catch.

comment:7 Changed 4 years ago by Ryan J Ollos

In 13285:

Refs #10797: Code cleanup: PEP-0008 changes, removed unused imports including unused import of pisa in web_ui.py. Removed Trac from install_requires, as this has been shown to cause problems (see #10607).

comment:8 Changed 3 years ago by Ryan J Ollos

In 13849:

0.2: web_context is only available since Trac 1.0, so enforce a minimum Trac version at runtime. Refs #8365, #10607.

comment:9 Changed 22 months ago by Ryan J Ollos

In 14819:

0.4dev: Require Trac in setup.py. Refs #8365, #10607.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.