Opened 11 years ago

Closed 10 years ago

#10759 closed defect (worksforme)

TemplateNotFound: Template "smp_admin_components.html" not found

Reported by: Ben Finn Owned by: falkb
Priority: low Component: SimpleMultiProjectPlugin
Severity: critical Keywords:
Cc: Trac Release: 0.12


On a fresh installation of the plugin, whenever I go to my admin pages, I get this error:

The Python traceback is as follows:

File "/usr/local/lib/python2.7/dist-packages/Trac-1.0-py2.7.egg/trac/web/", line 497, in _dispatch_request
File "/usr/local/lib/python2.7/dist-packages/Trac-1.0-py2.7.egg/trac/web/", line 233, in dispatch
File "/usr/local/lib/python2.7/dist-packages/Trac-1.0-py2.7.egg/trac/web/", line 960, in render_template
  template = self.load_template(filename, method=method)
File "/usr/local/lib/python2.7/dist-packages/Trac-1.0-py2.7.egg/trac/web/", line 931, in load_template
  return self.templates.load(filename, cls=cls)
File "/usr/lib/python2.7/dist-packages/genshi/template/", line 246, in load
  raise TemplateNotFound(filename, search_path)

System info:

Trac	1.0
Babel	0.9.6 (translations unavailable)
Docutils	0.8.1
Genshi	0.6 (with speedups)
mod_wsgi	3.3 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
MySQL	server: "5.5.27-log", client: "5.5.28", thread-safe: 1
MySQLdb	1.2.4c1
Pygments	1.4
Python	2.7.3 (default, Aug 1 2012, 05:27:35) [GCC 4.6.3]
pytz	2011k
setuptools	0.6
jQuery	1.7.2

Enabled plugins:

SimpleMultiProject	0.0.3dev	/usr/local/lib/python2.7/dist-packages/SimpleMultiProject-0.0.3dev-py2.7.egg
TicketLastCommentJumpPlugin	0.1	/usr/local/lib/python2.7/dist-packages/TicketLastCommentJumpPlugin-0.1-py2.7.egg
TracSubTicketsPlugin	/usr/local/lib/python2.7/dist-packages/TracSubTicketsPlugin-0.2.0.dev_20130104-py2.7.egg
TracWysiwyg	/usr/local/lib/python2.7/dist-packages/TracWysiwyg-

Attachments (0)

Change History (10)

comment:1 in reply to:  description Changed 11 years ago by Ben Finn

Sorry, two edits to that:

  1. - The actual error is this: TemplateNotFound: Template "smp_admin_components.html" not found
  1. - And it only happens in Admin -> Manage Projects when I click on Components or Projects.

comment:2 Changed 11 years ago by Ben Finn

Priority: highlow

I resolved the issue by manually copying the templates in.

comment:3 Changed 11 years ago by falkb

How did you install the plugin?

I created an egg file with python bdist_egg and copied the .egg file to Trac's plugin dir, and that always works well.

Does installation work for other plugins which also provide template files? If not, it may be a configuration problem with your installation.

comment:4 Changed 11 years ago by falkb

Not sure if it maybe a side effect of what was reported in #10798 and #10514. Please, try to update this plugin to >= [12535]

comment:5 in reply to:  4 Changed 11 years ago by falkb

Replying to falkb:

...Please, try to update this plugin to >= [12535]

benfinn, have you tried to update? What is your result?

comment:6 Changed 11 years ago by Ben Finn

Unfortunately, my contract ended before I had a chance to try the update. Sorry!

comment:7 Changed 11 years ago by anonymous

benfinn, could you answer the 2 questions in 3

comment:8 Changed 11 years ago by Ben Finn


For installation, I followed the exact steps listed in the under "Installation."

Other plugins which also provide template files worked properly.

comment:9 Changed 11 years ago by falkb

Owner: changed from Christopher Paredes to falkb

comment:10 Changed 10 years ago by falkb

Resolution: worksforme
Status: newclosed

Not reproducable, ticket originator not available for tests anymore. Please, reopen if still an issue.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain falkb.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.