Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11201 closed defect (cantfix)

Internal Server Error

Reported by: rui.moreira@… Owned by: Steffen Hoffmann
Priority: normal Component: BlackMagicTicketTweaksPlugin
Severity: normal Keywords: setuptools
Cc: ruimoreira29@… Trac Release: 0.12

Description (last modified by Ryan J Ollos)

Hello

I am installing the Account Manager Plugin on trac 0.12.4, when I enable the plugin I get a Internal Server Error from the tracd

Trac[main] ERROR: Internal Server Error:
Traceback (most recent call last):
File "/usr/lib/python2.6/site-packages/trac/web/main.py", line 525, in _dispatch_request dispatcher.dispatch(req)
File "/usr/lib/python2.6/site-packages/trac/web/main.py", line 246, in dispatch resp = chosen_handler.process_request(req)
File "/usr/lib/python2.6/site-packages/trac/web/chrome.py", line 471, in process_request in provider.get_htdocs_dirs() or []
File "build/bdist.linux-x86_64/egg/blackmagic/blackmagic.py", line 350, in get_htdocs_dirs return [('blackmagic', resource_filename(__name__, 'htdocs'))]
File "build/bdist.linux-x86_64/egg/pkg_resources.py", line 914, in resource_filename self, resource_name
File "build/bdist.linux-x86_64/egg/pkg_resources.py", line 1602, in get_resource_filename return self._extract_resource(manager, zip_path)
File "build/bdist.linux-x86_64/egg/pkg_resources.py", line 1617, in _extract_resource manager, os.path.join(zip_path, name)
File "build/bdist.linux-x86_64/egg/pkg_resources.py", line 1617, in _extract_resource manager, os.path.join(zip_path, name)
File "build/bdist.linux-x86_64/egg/pkg_resources.py", line 1629, in _extract_resource self.egg_name, self._parts(zip_path)
File "build/bdist.linux-x86_64/egg/pkg_resources.py", line 990, in get_cache_path self._warn_unsafe_extraction(extract_path) AttributeError: ResourceManager instance has no attribute '_warn_unsafe_extraction'

Attachments (0)

Change History (9)

comment:1 Changed 4 years ago by Ryan J Ollos

Description: modified (diff)

comment:2 Changed 4 years ago by Ryan J Ollos

Keywords: setuptools added

t:#11224 says that it's a setuptools issues, and that you should upgrade your setuptools to 0.7.6. If you are running distribute, it looks like you need to upgrade to 0.6.39 (see here). Which version of setuptools or distribute are you running? Try:

$ easy_install --version
Last edited 4 years ago by Ryan J Ollos (previous) (diff)

comment:3 Changed 4 years ago by rui.moreira@…

Hello,

Version of setuptools is

easy_install --version setuptools 0.7.5

comment:4 Changed 4 years ago by anonymous

Hello,

we have upgraded setuptools and now it works. Thank you so much .

comment:5 Changed 4 years ago by rui.moreira@…

Resolution: fixed
Status: newclosed

Hello,

we have upgraded setuptools and now it works. Thank you so much .

comment:6 Changed 4 years ago by Steffen Hoffmann

Component: AccountManagerPluginBlackMagicTicketTweaksPlugin

Fine. Please not that you could not even proof your claim against this plugin, because the error clearly raises from another plugin code, you see?

comment:7 Changed 4 years ago by Ryan J Ollos

Resolution: fixedinvalid

comment:8 Changed 4 years ago by rui.moreira@…

Sorry for that. I just pasted the wrong error, the same thing was happening with the AccountManagerPlugin.

comment:9 Changed 4 years ago by Ryan J Ollos

Resolution: invalidcantfix

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.