Modify

Opened 9 years ago

Closed 15 months ago

#11207 closed defect (wontfix)

TemplateNotFound: Template "tracmath_template.tex" not found

Reported by: dho@… Owned by: Kamil Kisiel
Priority: normal Component: TracMathPlugin
Severity: major Keywords:
Cc: Trac Release: 0.12

Description

How to Reproduce

While doing a GET operation on /query, Trac issued an internal error. (It randomly appears while I browsing the site.)

Request parameters:

{'order': u'priority', 'reporter': u'kevinyip', 'status': u'!closed'}

User agent: #USER_AGENT#

System Information

Trac 0.12.3
Babel 0.9.6
Docutils 0.8.1
Genshi 0.6
GIT 1.7.10.4
mod_python 3.3.1
Pygments 1.5
pysqlite 2.6.0
Python 2.7.3 (default, Jan 2 2013, 14:09:21)
[GCC 4.7.2]
pytz 2012c
setuptools 0.6
SQLite 3.7.13
Subversion 1.6.17 (r1128011)
jQuery #JQUERY#

Enabled Plugins

graphviz 0.7.5
TracGit 0.12.0.5dev
TracMath 0.5
TracWysiwyg 0.12.0.3
WikiTableMacro 0.1

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 198, in dispatch
    for handler in self.handlers:
  File "/usr/lib/python2.7/dist-packages/trac/core.py", line 78, in extensions
    return filter(None, [component.compmgr[cls] for cls in extensions])
  File "/usr/lib/python2.7/dist-packages/trac/core.py", line 213, in __getitem__
    component = cls(self)
  File "/usr/lib/python2.7/dist-packages/trac/core.py", line 119, in maybe_init
    init(self)
  File "build/bdist.linux-x86_64/egg/tracmath/tracmath.py", line 94, in __init__
    self.template = Chrome(self.env).load_template("tracmath_template.tex", method="text")
  File "/usr/lib/python2.7/dist-packages/trac/web/chrome.py", line 801, in load_template
    return self.templates.load(filename, cls=cls)
  File "/usr/lib/python2.7/dist-packages/genshi/template/loader.py", line 246, in load
    raise TemplateNotFound(filename, search_path)
TemplateNotFound: Template "tracmath_template.tex" not found

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by Kamil Kisiel

It looks like you're running the egg out of the build directory, so perhaps it can't find the template? Did you install with the bdist_egg method and copy the resulting egg to your plugin directory?

comment:2 Changed 15 months ago by Ryan J Ollos

Resolution: wontfix
Status: newclosed

Deprecated and removed. Source was on BitBucket and is no longer available. For alternate, see trac-mathjax.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Kamil Kisiel.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.