Opened 3 years ago

Closed 11 months ago

#11208 closed defect (fixed)

Installation bug

Reported by: gsanchez.dta@… Owned by: walnut
Priority: normal Component: ChildTicketsPlugin
Severity: normal Keywords: installation genshi
Cc: Trac Release: 0.12

Description (last modified by rjollos)

Hi, I am trying to install this plugin, but I have the following error:

Installed /usr/local/lib/python2.7/dist-packages/Tracchildtickets-2.5.2-py2.7.egg
Processing dependencies for Tracchildtickets==2.5.2
error: Installed distribution Genshi 0.7dev-r1180 conflicts with requirement Genshi>=0.6,<0.7dev

I saw that the requirement is:

['Trac>=0.12', 'Genshi>=0.5', 'Python>=2.4']

How can I resolve it? Thanks.

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by rjollos

  • Description modified (diff)
  • Keywords installation added; install bug conflict removed

comment:2 Changed 3 years ago by rjollos

Yeah, that is strange. Perhaps the error is coming from another plugin. Which other plugins do you have installed?

comment:3 Changed 11 months ago by rjollos

  • Resolution set to fixed
  • Status changed from new to closed

In 15066:

2.5.4dev: Revise installation requirements

Enforce Trac >= 1.0. Genshi and Python version is enforced
by Trac.

Fixes #10708, #11208. Refs #12364.

Add Comment

Modify Ticket

as closed The owner will remain walnut.
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.