Modify

Opened 4 years ago

Closed 5 months ago

#11232 closed defect (worksforme)

TypeError: not all arguments converted during string formatting

Reported by: Jay Owned by: Chris Nelson
Priority: normal Component: TracJsGanttPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

How to Reproduce

Whenever performing any action related to SubticketsPlugin:

While doing a POST operation on /newticket, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__EDITOR__1': u'textarea',
 '__FORM_TOKEN': u'ef2c99657b14a8bd24a19c6d',
 'field_blockedby': u'',
 'field_blocking': u'',
 'field_cc': u'',
 'field_comments': u'',
 'field_complete': u'',
 'field_component': u'DOORS',
 'field_description': u'The following artifacts need to be figured out/created:\r\n srd correctness\r\n sdd completeness\r\n tc completeness\r\n\r\nsdd correctness\r\n tc completeness\r\n\r\ntc correctness\r\n tp completeness\r\n\r\ntp correctness\r\n',
 'field_duedate': u'',
 'field_estimatedhours': u'0',
 'field_hours': u'0',
 'field_keywords': u'',
 'field_milestone': u'Current Action Items',
 'field_owner': u'< default >',
 'field_parents': u'253',
 'field_priority': u'1',
 'field_remaining': u'',
 'field_reporter': u'admin',
 'field_source': u'Internal',
 'field_startdate': u'',
 'field_summary': u'Dirt Artifacts Creationg',
 'field_totalhours': u'0',
 'field_type': u'task',
 'field_version': u'A400M',
 'submit': u'Create ticket'}

User agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.72 Safari/537.36

System Information

Trac 1.0
Genshi 0.6 (without speedups)
pysqlite 2.6.0
Python 2.7.3 (default, Apr 10 2012, 23:31:26) [MSC v.1500 32 bit (Intel)]
setuptools 0.6c11
SQLite 3.6.21
Subversion 1.7.6 (r1370777)
jQuery 1.7.2

Enabled Plugins

BlockDiagPlugin 0.5.1
Color Rev
GridModify 0.1.6dev
IniAdmin 0.2
TicketImport 0.8.3
timingandestimationplugin 1.2.8
Trac-jsGantt 0.10
TracCustomFieldAdmin 0.2.8
TracDateField 3.0.0dev
TracMasterTickets 3.0.5dev
TracSubTicketsPlugin 0.2.0.dev-20121009
TracSumFields 1.0.1
TracWysiwyg 0.12.0.4

Python Traceback

Traceback (most recent call last):
  File "C:\usr\virtualenvs\TracSites\lib\site-packages\trac\web\main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "C:\usr\virtualenvs\TracSites\lib\site-packages\trac\web\main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "C:\usr\virtualenvs\TracSites\lib\site-packages\trac\ticket\web_ui.py", line 180, in process_request
    return self._process_newticket_request(req)
  File "C:\usr\virtualenvs\TracSites\lib\site-packages\trac\ticket\web_ui.py", line 465, in _process_newticket_request
    self._do_create(req, ticket) # (redirected if successful)
  File "C:\usr\virtualenvs\TracSites\lib\site-packages\trac\ticket\web_ui.py", line 1289, in _do_create
    ticket.insert()
  File "C:\usr\virtualenvs\TracSites\lib\site-packages\trac\ticket\model.py", line 255, in insert
    listener.ticket_created(self)
  File "C:\usr\virtualenvs\TracSites\lib\site-packages\tracjsgantt\tracpm.py", line 2929, in ticket_created
    self.rescheduleTickets(ticket, {})
  File "C:\usr\virtualenvs\TracSites\lib\site-packages\tracjsgantt\tracpm.py", line 2735, in rescheduleTickets
    ids = self._findAffected(ticket, old_values)
  File "C:\usr\virtualenvs\TracSites\lib\site-packages\tracjsgantt\tracpm.py", line 2437, in _findAffected
    toExplore = more(border)
  File "C:\usr\virtualenvs\TracSites\lib\site-packages\tracjsgantt\tracpm.py", line 2393, in more
    n = set(self.pm._reachable(list(ids)))
  File "C:\usr\virtualenvs\TracSites\lib\site-packages\tracjsgantt\tracpm.py", line 614, in _reachable
    toExplore = neighbors(border)
  File "C:\usr\virtualenvs\TracSites\lib\site-packages\tracjsgantt\tracpm.py", line 582, in neighbors
    1))
  File "C:\usr\virtualenvs\TracSites\lib\site-packages\tracjsgantt\tracpm.py", line 642, in _followLink
    node_list = [format % tid for tid in origins]
TypeError: not all arguments converted during string formatting

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by Chris Nelson

Can you post the trac.ini section for TracPM? I suspect your parent_format setting is wrong.

comment:2 Changed 5 months ago by Ryan J Ollos

Resolution: worksforme
Status: newclosed

Closing due to no reply.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Chris Nelson.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.