Modify

Opened 3 years ago

Closed 3 years ago

#11526 closed defect (duplicate)

AttributeError: 'NoneType' object has no attribute 'youngest_rev'

Reported by: Yegor Owned by:
Priority: normal Component: PeerReviewPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

How to Reproduce

While doing a GET operation on /peerReviewBrowser, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'path': '/'}

User agent: #USER_AGENT#

System Information

Trac 0.12.3
Trac 0.12.3
Agilo 0.9.7
Babel 0.9.6
Docutils 0.8.1
Genshi 0.6
mod_wsgi 3.3 (WSGIProcessGroup traclocal WSGIApplicationGroup %{GLOBAL})
Pygments 1.4
pysqlite 2.6.0
Python 2.7.3 (default, Sep 26 2013, 20:13:52)
[GCC 4.6.3]
Python 2.7.3 (default, Sep 26 2013, 20:13:52)
[GCC 4.6.3]
RPC 1.1.2
setuptools 0.6
setuptools 0.6
SQLite 3.7.9
Subversion 1.8.3 (r1516576)
jQuery #JQUERY#

Enabled Plugins

agilo 0.9.7
TracCodeReview 2.1-toddlerdev
TracXMLRPC 1.1.2
TracXPDev 1.0

Python Traceback

Traceback (most recent call last):
  File "/opt/trac/current/lib/python2.7/site-packages/Trac-0.12.3-py2.7.egg/trac/web/main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "/opt/trac/current/lib/python2.7/site-packages/Trac-0.12.3-py2.7.egg/trac/web/main.py", line 243, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-x86_64/egg/codereview/peerReviewBrowser.py", line 96, in process_request
    rev = repos.youngest_rev
AttributeError: 'NoneType' object has no attribute 'youngest_rev'

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by Jun Omae

Component: SELECT A HACKPeerReviewPlugin
Resolution: duplicate
Status: newclosed
Trac Release: 0.12

A duplicate of #7034. Please upgrade to the latest.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.