Modify

Opened 15 years ago

Closed 15 years ago

#1161 closed defect (duplicate)

TracBlog day out of range when navigating blog

Reported by: keith.rogers@… Owned by: John Hampton
Priority: low Component: TracBlogPlugin
Severity: minor Keywords: TracBlog day range
Cc: Trac Release: 0.10

Description

I'm getting a "day is out of range for month" error when navigating through the blog - guess it's because today is the 31st, so when I try to view a month with fewer days it messes up (quick fix is to specify the day as a parameter in the url)

Traceback (most recent call last):
  File "/usr/local/python/lib/python2.4/site-packages/trac/web/main.py", line 339, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/python/lib/python2.4/site-packages/trac/web/main.py", line 224, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-x86_64/egg/tBlog/web_ui.py", line 207, in process_request
  File "build/bdist.linux-x86_64/egg/tBlog/web_ui.py", line 311, in _generate_blog
  File "build/bdist.linux-x86_64/egg/tBlog/web_ui.py", line 326, in _generate_calendar
ValueError: day is out of range for month

Attachments (0)

Change History (2)

comment:1 Changed 15 years ago by anonymous

Keywords: TracBlog added
Summary: day out of range when navigating blogTracBlog day out of range when navigating blog

comment:2 Changed 15 years ago by John Hampton

Resolution: duplicate
Status: newclosed

duplicate of #1060

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain John Hampton.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.