Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11631 closed defect (duplicate)

src_attachment_dir is different from real location

Reported by: Giuseppe Ursino Owned by: Jeff Hammel
Priority: normal Component: TicketMoverPlugin
Severity: blocker Keywords:
Cc: Trac Release: 1.0

Description

I'm trying to use this plugin to move my tickets from different environment.

The ticket move correctly, but attachment files didn't copy.

Indeed in source ticket description it shows "moved to /ticket/XXX", where XXX is the number of ticket; but there isn't the previous url.

Instead in the dest ticekt description it show the correct url.

I also show that if there is an attach, the source and dest description are correct with all url, but the attachment files are not copied.

I saw that the variabile: "src_attachment_dir" was not correct. infact the attachment files has different name.

Example:

src_attachment_dir=/home/trac/prjenv/example/attachments/ticket/44

instead the correct folder is:

/home/trac/prjenv/example/files/attachments/ticket/98f/98fbc42faedc02492397cb5962ea3a3ffc0a9243/6c866e78b757537003000122c1cba5c5fd005815.exe

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by Giuseppe Ursino

My system:

Trac 1.0.1 
Genshi 0.6 (without speedups) 
psycopg2 2.0.7 
Python 2.5.2 (!r252:60911, Jan 24 2010, 14:53:14) [GCC 4.3.2] 
setuptools 0.6c8 
Subversion 1.5.1 (!r32289) 
jQuery 1.7.2 

TicketMoverPlugin 0.1.2: /usr/lib/python2.5/site-packages/!TicketMoverPlugin-0.1.2-py2.5.egg

Last edited 4 years ago by Ryan J Ollos (previous) (diff)

comment:2 Changed 4 years ago by Giuseppe Ursino

Trac Release: 1.0

comment:3 Changed 4 years ago by Jun Omae

Resolution: duplicate
Status: newclosed

A duplicate of #11188.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jeff Hammel.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.