Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#11970 closed defect (duplicate)

Blank graph on Trac 1.0.1

Reported by: paul@… Owned by: Ryan J Ollos
Priority: normal Component: TracTicketStatsPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

I've installed the ticketstats plugin, both 2.2.0 and 3.0.0dev, onto my Trac 1.0.1 site. I get the Ticket Stats button in the top bar, and the controls at the bottom, but the main area just shows Ticket Statistics, the main area is blank.

I have tried adding

[ticketstats] yui_base_url = http://yui.yahooapis.com/2.9.0

and

[ticketstats] yui_base_url = http://yui.yahooapis.com/3.7.12

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

This is a duplicate of #11440. See that ticket for hints on getting it to work.

comment:2 Changed 8 years ago by paul@…

Thanks for the quick response. Yes, the workaround to host YUI 2.9.0 locally worked for me. Here's the details, on Ubuntu 14 server.

  1. Install tracticketstatsplugin 3.0.0dev
    # cd tracticketstatsplugin
    # easy_install trunk
    Processing trunk
    Writing /.../tracticketstatsplugin/trunk/setup.cfg
    Running setup.py -q bdist_egg --dist-dir /.../tracticketstatsplugin/trunk/egg-dist-tmp-s54pZh
    zip_safe flag not set; analyzing archive contents...
    Adding Tracticketstats 3.0.0dev to easy-install.pth file
    
    Installed /usr/local/lib/python2.7/dist-packages/Tracticketstats-3.0.0dev-py2.7.egg
    Processing dependencies for Tracticketstats==3.0.0dev
    Finished processing dependencies for Tracticketstats==3.0.0dev
    
  2. cd /server/www
  3. wget http://yui.github.io/yui2/archives/yui_2.9.0.zip
  4. unzip yui_2.9.0.zip
  5. chown -R www-data yui
  6. Add to trac.ini
    [ticketstats]
    yui_base_url = /yui
    
  7. service apache2 reload
  8. Then go the the Trac Admin page, click Plugins and enable Tracticketstats 3.0.0dev

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.