Opened 11 years ago

Closed 11 years ago

#1213 closed defect (fixed)

Problems with subversionpathtotestcases?

Reported by: mrudolph@… Owned by: edunne
Priority: normal Component: TestCaseManagementPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description (last modified by Noah Kantrowitz)

When I try to run Test Runs, I got the following trac error:

Traceback (most recent call last):
  File "/var/lib/python-support/python2.4/trac/web/", line 387, in dispatch_request
  File "/var/lib/python-support/python2.4/trac/web/", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/testManagementPlugin/", line 83, in process_request
  File "build/bdist.linux-i686/egg/testManagementPlugin/", line 40, in process_testmanager_request
  File "build/bdist.linux-i686/egg/testManagementPlugin/", line 47, in hasTestCases
  File "/var/lib/python-support/python2.4/trac/versioncontrol/", line 110, in has_node
    return self.repos.has_node(path, rev)
  File "/var/lib/python-support/python2.4/trac/versioncontrol/", line 319, in has_node
    rev_root = fs.revision_root(self.fs_ptr, rev, pool())
  File "/var/lib/python-support/python2.4/libsvn/", line 224, in svn_fs_revision_root
    return apply(_fs.svn_fs_revision_root, args)
TypeError: argument number 2: 

Could it be, that the pathotestcase-variable is set wrong? But I dont' know how to set it correctly. Our trac starts at the root of the svn and the folder testcases was created under CUSTOM/scr/testcases.

Attachments (0)

Change History (10)

comment:1 Changed 11 years ago by anonymous

not sure. I'll try and duplicate the error.

comment:2 Changed 11 years ago by anonymous

I'm pretty sure it's not a path problem. If a path error occurs you should get an error page that looks like this:

There appears to be a configuration problem for the testcaseplugin. The reason could be one of the following: 
there are no testcases in subversion at the specified path 
the trac.ini file is missing the config variable SubversionPathToTestCases under the section 'testcaseExtension' 
the current user is not allowed to access the subversion repository using the current trac acount 

Error message if any specified here : Path in config file is does not exist in subversion...resolved path was: /testcases/asdfasdf 

I triggered this error by appending the asdfasdf to config value of subversionpathtotestcases under the testManagementExtension section in the trac config file.

I was thinking that this could be a lib version problem. Specifically the python2.4/libsvn/ Although if you can browse the source code by clicking the browse source tab in TRAC then that probably isn't the problem.

Which version of Trac do you have installed? Is it 0.10 or 0.10.1 etc? Which version of subversion?

You could try adding a leading slash to your subversionpathtotestcases value. This value gets appended to the repository_dir config value found under the TRAC section in the trac.config file.

I'd definately like to help get you up and running on this so get back to me on this whenever you can.

comment:3 Changed 11 years ago by anonymous

Owner: changed from edunne to anonymous
Status: newassigned

comment:4 Changed 11 years ago by anonymous

Owner: changed from anonymous to edunne
Status: assignednew

comment:5 Changed 11 years ago by Noah Kantrowitz

Description: modified (diff)

Fixing formatting.

comment:6 Changed 11 years ago by anonymous

subversion: 1.4.2dfsg1-2 trac: 0.10.3-1

Browing the source code works in the trac system.

I tried any combination for the path-variable. But all lead to the same error.

comment:7 Changed 11 years ago by edunne

ok thanks, I'll reconfigure my testing environment to match your trac and subversion setup and try to duplicate the problem.

comment:8 Changed 11 years ago by anonymous

Did you check object in 'rev'? The error "TypeError: argument number 2" says you should check it. 'rev' might be string although 'long' is required.

comment:9 Changed 11 years ago by anonymous

yeah I've duplicated the problem. This is a change between trac 10.2 and 10.3. I'll fix this issue.

Thanks for the anonymous posting there.

comment:10 Changed 11 years ago by edunne

Resolution: fixed
Status: newclosed

fixed in rev : 2026 on trunk

ok, I ended up commenting out the has_node call as this is actually a bug in TRAC 10.3.

So for now the testManagement plugin won't check to see if the node exists in the repository before trying to access the node.

If the node doesn't exist subversion puts up a half decent error message so it it's fine to try and access the path just not super elegant.

When TRAC posts a path for the problem I'll re-enable the code to check for the node.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain edunne.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.