Modify

Opened 9 years ago

Closed 6 months ago

#12161 closed defect (fixed)

CC-Selector button position incorrect since Trac 1.0.3

Reported by: Jeremy Dunn Owned by: Dirk Stöcker
Priority: normal Component: CcSelectorPlugin
Severity: minor Keywords:
Cc: Trac Release: 1.0

Description

In Trac 1.0.1 the CC-select button (">") was to the right of the CC field, but to the left of the vertical line separating left- and right-hand columns of fields.

Since 1.0.3 (we skipped 1.0.2 update) the CC field was made longer, so the CC button overwrites the field to the right of CC.

The CC Selector button should either be moved to a different position (where?) or else the CC-S code should shorten the CC: field back to the old length, so there is space.

See attached screenshot.

Attachments (2)

Trac103-CCSelectorPositionProblem.PNG (26.1 KB) - added by Jeremy Dunn 9 years ago.
Screenshot of CC-Selection position problem
20150126_cc-sel_new-button-placement-proposal.png (2.2 KB) - added by Steffen Hoffmann 9 years ago.
visual proposal for cc dialog button placement inside cc ticket field

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by Jeremy Dunn

Screenshot of CC-Selection position problem

comment:1 Changed 9 years ago by anonymous

workaround for the time being, in myticket.css:

#field-cc {
  width: 80% !important;
}

comment:2 Changed 9 years ago by Ryan J Ollos

The changes were made in Trac milestone:1.0.2, trac:#11471. The fix in comment:1 is probably on the right path.

comment:3 Changed 9 years ago by Steffen Hoffmann

Could you imagine an alternative placement, inside the input field? Like so:

visual proposal for cc dialog button placement inside cc ticket field

This could be more independent of input filed length, so more generically acceptable.

Changed 9 years ago by Steffen Hoffmann

visual proposal for cc dialog button placement inside cc ticket field

comment:4 in reply to:  3 Changed 9 years ago by Jeremy Dunn

Replying to hasienda:

Could you imagine an alternative placement, inside the input field? Like so:

visual proposal for cc dialog button placement inside cc ticket field

This could be more independent of input filed length, so more generically acceptable.

no objection. My only problem with the placement change caused by Trac 1.0.2 is that it overlays a nearby field. As long as we can stop it from doing that, any solution is fine.

comment:5 Changed 9 years ago by Ryan J Ollos

I just started using the plugin. I like the idea in comment:3. I noticed that DateFieldPlugin has the same issue. If you come up with a solution for this plugin, I'll probably implement the same for DateFieldPlugin.

comment:6 Changed 7 years ago by Ryan J Ollos

Owner: Steffen Hoffmann deleted

comment:7 Changed 6 months ago by Ryan J Ollos

Owner: set to Dirk Stöcker
Status: newassigned

comment:8 Changed 6 months ago by Dirk Stöcker

Resolution: fixed
Status: assignedclosed

In 18597:

CcSelectorPlugin: fix #12161 - incorrect button alignment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Dirk Stöcker.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.