Modify

Opened 7 years ago

Closed 7 years ago

#12162 closed defect (duplicate)

ticket can not submit

Reported by: wang.chengcheng@… Owned by: Rob Guttman
Priority: normal Component: DynamicFieldsPlugin
Severity: major Keywords:
Cc: Trac Release: 1.0

Description (last modified by Ryan J Ollos)

when I installed the dynamicfieldsplugin and use validate rules and setrules both.

the setrules as below:

project_name.set_to_!_when_type = CASE (overwrite)
project_name.set_to_case-option_when_type = MRQ (overwrite)

I switched the type from CASE to MRQ and then from MRQ to CASE. After that I filled some info but leave one or two mandatory option not filled(xxxx.invalid_if = ). then some "must not empty" show up.

after click the msg and filled the mandatory option. click the submit button. no response.

Could you help check it?

Attachments (0)

Change History (6)

comment:1 Changed 7 years ago by Ryan J Ollos

Description: modified (diff)

comment:2 Changed 7 years ago by anonymous

Any update for this?

comment:3 Changed 7 years ago by Ryan J Ollos

Please provide:

  • The entire [ticket-custom] section from trac.ini
  • Exact version of Trac
  • List of installed plugins

comment:4 Changed 7 years ago by anonymous

  1. the entire ticket-custom section:
    competitor_info = textarea
    competitor_info.cols = 30
    competitor_info.format = plain
    competitor_info.invalid_if =
    competitor_info.label = 竞争对手信息*
    competitor_info.options =
    competitor_info.order = 27
    competitor_info.rows = 4
    competitor_info.set_to__when_type = MRQ (overwrite)
    competitor_info.set_to_mrq-option_when_type = CASE (overwrite)
    competitor_info.value =
    complete_percent = select
    complete_percent.label = 完成度
    complete_percent.options = 0%|10%|20%|30%|40%|50%|60%|70%|80%|90%|100%
    complete_percent.order = 15
    complete_percent.value =
    customer_contacts = text
    customer_contacts.format = plain
    customer_contacts.label = 用户联系人
    customer_contacts.options =
    customer_contacts.order = 7
    customer_contacts.value =
    customer_tel = text
    customer_tel.format = plain
    customer_tel.label = 用户联系方式
    customer_tel.options =
    customer_tel.order = 8
    customer_tel.value =
    end_time = text
    end_time.date = true
    end_time.date_empty = on
    end_time.format = plain
    end_time.label = 完成日期
    end_time.options =
    end_time.order = 13
    end_time.value =
    enduser_name = text
    enduser_name.format = plain
    enduser_name.label = 最终用户名称
    enduser_name.options =
    enduser_name.order = 21
    enduser_name.value =
    endusra_name =
    endusra_name.order = 35
    expected_time = text
    expected_time.format = plain
    expected_time.label = 预期时间(小时)
    expected_time.options =
    expected_time.order = 14
    expected_time.value =
    feedback_info = textarea
    feedback_info.cols = 30
    feedback_info.format = plain
    feedback_info.label = 反馈意见
    feedback_info.options =
    feedback_info.order = 33
    feedback_info.rows = 4
    feedback_info.value =
    field_version = textarea
    field_version.cols = 30
    field_version.format = plain
    field_version.invalid_if =
    field_version.label = 现场版本信息*
    field_version.options =
    field_version.order = 26
    field_version.rows = 4
    field_version.set_to__when_type = MRQ (overwrite)
    field_version.set_to_mrq-option_when_type = CASE (overwrite)
    field_version.value =
    fixed_department = select
    fixed_department.label = 解决部门
    fixed_department.options = |L1|L2|L3
    fixed_department.order = 18
    fixed_department.value =
    fixed_person = text
    fixed_person.format = plain
    fixed_person.label = 解决人
    fixed_person.options =
    fixed_person.order = 17
    fixed_person.value =
    issue_rate = select
    issue_rate.invalid_if = ---请选择---
    issue_rate.label = 问题复现级别*
    issue_rate.options = ---请选择---|必现|条件复现|很难复现|无法复现|不允许复现|case-option
    issue_rate.order = 11
    issue_rate.set_to_!_when_type = CASE (overwrite)
    issue_rate.set_to_case-option_when_type = MRQ (overwrite)
    issue_rate.value = ---请选择---
    need_support_time = text
    need_support_time.date = true
    need_support_time.date_empty = on
    need_support_time.format = plain
    need_support_time.label = 需要支持时间
    need_support_time.options =
    need_support_time.order = 6
    need_support_time.value =
    need_support_tupe = select
    need_support_tupe.label = 需要支持类型
    need_support_tupe.options = ON CALL|ON SITE
    need_support_tupe.order = 5
    need_support_tupe.value =
    new_version_time = text
    new_version_time.format = plain
    new_version_time.label = 预计版本发布时间
    new_version_time.options =
    new_version_time.order = 34
    new_version_time.value =
    outage_consume = text
    outage_consume.format = plain
    outage_consume.label = OUTAGE时长(分钟)
    outage_consume.options =
    outage_consume.order = 16
    outage_consume.value =
    platform = text
    platform.format = plain
    platform.invalid_if =
    platform.label = 平台版本*
    platform.options =
    platform.order = 2
    platform.set_to__when_type = CASE (overwrite)
    platform.set_to_case-option_when_type = MRQ (overwrite)
    platform.value =
    products_type = select
    products_type.label = 产品型号
    products_type.options = ---请选择---|NVR2100|NVR2200|SVR3100|SVR3300|NVR2100C|DCE1001|DCE1002|DCE3004|DCE3008|JBOD3016P|EGW101|EGW1012|NKB3000
    products_type.order = 10
    products_type.value =
    project_background = textarea
    project_background.cols = 30
    project_background.format = plain
    project_background.invalid_if =
    project_background.label = 项目背景*
    project_background.options =
    project_background.order = 25
    project_background.rows = 4
    project_background.set_to__when_type = MRQ (overwrite)
    project_background.set_to_mrq-option_when_type = CASE (overwrite)
    project_background.value =
    project_name = select
    project_name.invalid_if = ---请选择---
    project_name.label = 项目*
    project_name.options = ---请选择---|演示项目|甘肃邮电学校|case-option
    project_name.order = 1
    project_name.set_to_!_when_type = CASE (overwrite)
    project_name.set_to_case-option_when_type = MRQ (overwrite)
    project_name.value =
    projects = text
    projects.format = plain
    projects.label = 项目
    projects.options =
    projects.order = 36
    projects.value = XVR
    province_info = select
    province_info.invalid_if = ---请选择---
    province_info.label = 省份*
    province_info.options = ---请选择---|1-安徽省|2-澳门特别行政区|3-北京市|4-重庆市|5-福建省|6-甘肃省|7-广东省|8-广西壮族自治区|9-贵州省|10-海南省|11-河北省|12-黑龙江省|13-河南省|14-湖北省|15-湖南省|16-江苏省|17-江西省|18-吉林省|19-辽宁省|20-内蒙古|21-宁夏回族自治区|22-青海省|23-陕西省|24-山东省|25-上海市|26-山西省|27-四川省|28-台湾省|29-天津市|30-香港特别行政区|31-新疆维吾尔族自治区|32-西藏自治区|33-云南省|34-浙江省|mrq-option
    province_info.order = 20
    province_info.set_to_!_when_type = MRQ (overwrite)
    province_info.set_to_mrq-option_when_type = CASE (overwrite)
    province_info.value =
    reason_forissue = textarea
    reason_forissue.cols = 80
    reason_forissue.format = plain
    reason_forissue.label = 问题及解决方法
    reason_forissue.options =
    reason_forissue.order = 19
    reason_forissue.rows = 4
    reason_forissue.value =
    reporter_department = text
    reporter_department.format = plain
    reporter_department.invalid_if =
    reporter_department.label = 填表人部门*
    reporter_department.options =
    reporter_department.order = 29
    reporter_department.set_to__when_type = MRQ (overwrite)
    reporter_department.set_to_mrq-option_when_type = CASE (overwrite)
    reporter_department.value =
    reporter_email = text
    reporter_email.format = plain
    reporter_email.invalid_if =
    reporter_email.label = 填表人邮件地址*
    reporter_email.options =
    reporter_email.order = 32
    reporter_email.set_to__when_type = MRQ (overwrite)
    reporter_email.set_to_mrq-option_when_type = CASE (overwrite)
    reporter_email.value =
    reporter_name = text
    reporter_name.format = plain
    reporter_name.invalid_if =
    reporter_name.label = 填表人姓名*
    reporter_name.options =
    reporter_name.order = 28
    reporter_name.set_to__when_type = MRQ (overwrite)
    reporter_name.set_to_mrq-option_when_type = CASE (overwrite)
    reporter_name.value =
    reporter_phone = text
    reporter_phone.format = plain
    reporter_phone.invalid_if =
    reporter_phone.label = 填表人手机*
    reporter_phone.options =
    reporter_phone.order = 30
    reporter_phone.set_to__when_type = MRQ (overwrite)
    reporter_phone.set_to_mrq-option_when_type = CASE (overwrite)
    reporter_phone.value =
    reporter_tel = text
    reporter_tel.format = plain
    reporter_tel.invalid_if =
    reporter_tel.label = 填表人分机*
    reporter_tel.options =
    reporter_tel.order = 31
    reporter_tel.set_to__when_type = MRQ (overwrite)
    reporter_tel.set_to_mrq-option_when_type = CASE (overwrite)
    reporter_tel.value =
    request_type = select
    request_type.invalid_if =
    request_type.label = 需求属性*
    request_type.options = |与近期合同相关的需求|与合同相关的一般需求|与合同无关的产品长期改进需求|mrq-option
    request_type.order = 24
    request_type.set_to_!_when_type = MRQ (overwrite)
    request_type.set_to_mrq-option_when_type = CASE (overwrite)
    request_type.value =
    start_time = text
    start_time.date = true
    start_time.date_empty = on
    start_time.format = plain
    start_time.label = 开始日期
    start_time.options =
    start_time.order = 12
    start_time.value =
    status_now = select
    status_now.label = 当前状态*
    status_now.options = 已解决|需要支持|待观察|转新需求
    status_now.order = 3
    status_now.value = 需要支持
    support_method = select
    support_method.label = 问题解决手段*
    support_method.options = 电话支持|邮件支持|现场支持|在线支持
    support_method.order = 4
    support_method.value = 在线支持
    user_company = text
    user_company.format = plain
    user_company.label = 用户单位名称
    user_company.options =
    user_company.order = 22
    user_company.value =
    user_property = select
    user_property.label = 用户属性*
    user_property.options = 电信|移动|联通|专网|mrq-option
    user_property.order = 23
    user_property.set_to_!_when_type = MRQ (overwrite)
    user_property.set_to_mrq-option_when_type = CASE (overwrite)
    user_property.value =
    whether_expired = select
    whether_expired.label = 是否过期
    whether_expired.options = 是|否
    whether_expired.order = 9
    whether_expired.value = 
    
  2. Exact trac Version: 1.0.2
  3. List of installed plugins:
Last edited 7 years ago by Ryan J Ollos (previous) (diff)

comment:5 Changed 7 years ago by Ryan J Ollos

Are you running the latest version of the plugin from the dynamicfieldsplugin/0.12 branch? The latest version is 2.2.0.

comment:6 Changed 7 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Should be fixed in [14516]. Please upgrade to the latest.

Closing as a duplicate of #12258. Please reopen if you continue to see the issue after upgrading.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Rob Guttman.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.